New Server Provision Skipping WP Install

Hey there.

Provisioned a fresh AWS instance, everything went well, php7 installed, remote mysql, etc.

When I ran a deploy, it put all the files correctly on the server, however, the database isn’t being installed.

The status for the deploy shows that the following are being skipped:

TASK [deploy : WordPress Installed?] *******************************************
ok: []

TASK [deploy : Update WP theme paths] ******************************************
skipping: []

TASK [deploy : Update WP database] *********************************************
skipping: []

TASK [deploy : Warn about updating network database.] **************************
skipping: []

TASK [deploy : Update WP network database] *************************************
skipping: []

Not sure what I’m doing wrong. My production server is using remote-mysql, and works fine. There is no difference in my wordpress-sites other than the host: staging instead of www, and different mysql credentials.

Trellis does not install WP on remote servers. It’s left up to you to take of that how you wish.

Workflow is:

  1. Provision server
  2. Deploy
  3. Install (or load DB dump)

It’s always been this way.

I’m aware of that. When you run the deploy, it then prompts you to install a vanilla version of Wordpress. However, I’m not even getting that far. I’m getting a white screen with a php memory allocation error on wp-formatting.php.

This is a 4gb brand new AWS instance.

What have you done to debug your issue? You haven’t provided any information regarding what you have tried so far.

I’ve uploaded the database via Sequel Pro. The config is pointing to the correct place, yet I’m still getting memory errors. I’m going to try to spin up a brand new instance, and see if that has anything to do with anything.