Newbie: 404 On Bedrock Install

I followed the instructions to the best of my ability, but I’m receiving a 404 error after installation.

I suspect it has something to do with my .env file and the site paths, but I’ve tried several combinations for the paths without getting a different result.

Could someone enlighten me? Thank you!

Is this just Bedrock on its own or via Trellis?

If you’d like help, I suggest providing examples of your .env file and webserver configuration (remove any private data first). Otherwise it’s very hard to help.

Thanks for the swift reply.

I’m not using Trellis. This is a custom built server on AWS > EC2, running NGinx, HHVM, Reddis and a few other things.

Here is my .env file. When I ran the advised composer command it created “bedrock” folder inside my public_html.

So the path is: /home/ I guess?

Nginx’s root should be /home/ I guess.

A 404 is likely a webserver configuration issue. That’s a little beyond the scope of this forum. Obviously you’d need a working Nginx with PHP for any normal WordPress site, then you just need to set root to that web/ subdir.

Thanks for the reply.

I should say, this web server runs something like 40 WordPress websites. So that’s why this error is particularly surprising to me.

Because it’s a shared host, I couldn’t change the global NGinx root. But I believe I can change it per-site. So I will investigate and report back here once I’ve confirmed and tried it in the case others are experiencing this.

Thank you!

@swalkinshaw, and others reading this, as you suggested I failed to set the VHost correctly.

In my case, I opened /etc/nginx/sites-enabled/mysite and added or edited the following:

  • Line 4 - root /home/;
  • Line 14 - fastcgi_param SCRIPT_FILENAME /home/mysite.comm/public_html/bedrock/web/wp/$fastcgi_script_name;
  • Line 18 - fastcgi_param DOCUMENT_ROOT /home/;

Thank you!

1 Like