No option prompts for composer sage install - on windows

Hi, Just tried creating a new project with composer, however i was expecting options for title, framework,fonts etc, but didnt get any?
Not too sure if this is now normal or if im missing something?

i do see this in the command line after creation:

TTY mode is not supported on windows platform
Some interactive parts of post-create-project routine might be skipped
running the sage cli tool manually should still work.

Open issue:

Might not be relevant after @QWp6t’s rewrite of sage-installer into Node/JS is published

I ran into this as well. To work around it, run these commands from within your theme directory:

./vendor/bin/sage meta
./vendor/bin/sage config
./vendor/bin/sage preset

meta allows you to specify the metadata for your theme (the name, etc., that goes in style.css).

config allows you to specify your theme’s dev URL and theme directory.

preset allows you to set up the theme with one of the supported frameworks (Bootstrap, etc.) and Font Awesome.


I have no idea why, but on Windows 10 today, (with Laragon as dev server) I had to type the commands this way:
vendor\bin\sage meta
vendor\bin\sage config
vendor\bin\sage preset

Posting this here in case someone else needs it.


@maguijo looks like a difference in terminal syntax. On Unix-based systems (Linux, OS X) and terminals for Windows that emulate them (Cygwin, Git Bash, etc.), you use “/” and so on in your paths. In Windows, you use “”. I haven’t used Windows 10 / WSL specifically, but I’m guessing the same convention would hold true: most likely, if you’re using the Powershell, you would use Windows-style formatting for your commands, and if you’re using a shell from/imitating a Unix-based system, you would use that style.

Thanks for posting!

Hi all,

New to Sage. I have this same problem on Windows 10, and running the commands @mmirus suggested doesn’t work (in either format). It says no such file or directory. Am I just looking in the wrong place?


Edit: I was looking in the wrong place… Seems to be working now. Fingers crossed

1 Like