Npm install multiple errors within theme directory


I’ve used Sage multiple times, but my laptop is erased. So I’m trying to build a new theme with a fresh install, but I get stuck when running “npm install” in my theme directory, a list of a bunch of errors. Bower seems to work fine.

I’ve tried so many things, but can’t really find the cause of it.

In this link you can see the errors.

Can somebody please help me out? I’ve been trying to figure this out for more than 10 hours.

Thanks a lot in forward!

At the top of this forum is a sticky thread: Npm Debugging Guidelines (Failed npm install, bower install, or gulp build? Read this)

What have you done so far to try and fix your problems?

Hi Ben,

Thanks for your help.
I’ve done the debugging multiple times and it seems the problem lays with gulp and something with my locations i think, e.g. when I do gulp watch:

  • I’ve reinstalled everything multiple times on multiple drives.
  • npm latest
  • cache clear, but same error when running npm install in the theme directory
  • recognizes Bower version, but when i enter ‘‘gulp’’ it says: local gulp not found in ~ try running npm install gulp. I install it again, says:

It seems my theme recognizes gulp, but there is still something going wrong:

Tried other themes as well, same problem.

Exactly my problem: