Roots Discourse

Old version of Trellis needs Python 2.* for deployment

Stuck with trying to get deploys working with an older install of Trellis.

I’ve setup pyenv to be able to switch versions easily, but I still can’t get it to work. Some one that has been able to set this up successfully that can guide me? I’ve run pyenv local 2.7.18 in the trellis folder:

cd trellis/
python --version
Python 2.7.18
./bin/deploy.sh production mysite.tld
[WARNING]: Skipping plugin (/mysite.tld/trellis
/lib/trellis/plugins/vars/version.py) as it seems to be invalid: Trellis does
not yet support Python 3.9.7.  Please use Python 2.7.

Running ansible --version does indicate that I’m still on 3.*:

ansible --version
ansible 2.10.13
config file = /mysite.tld/trellis/ansible.cfg
configured module search path = ['/Users/me/.ansible/plugins/modules', '/usr/share/ansible/plugins/modules']
ansible python module location = /usr/local/lib/python3.9/site-packages/ansible
executable location = /usr/local/bin/ansible
python version = 3.9.7 (default, Sep  3 2021, 12:36:14) [Clang 11.0.0 (clang-1100.0.33.17)]

Tried to fix that by downgrading ansible, but that does not seem to work
pip install ansible==2.5.3 gets me Successfully installed ansible-2.5.3 but running ansible --version after that still shows 2.10.13 and 3.9.7

What am I missing?