PHP 7.1 -fmp error on server.yml playbook

I’m getting an errot due to php7.1

fatal: [174.138.53.45]: FAILED! => {“changed”: false, “msg”: “Unable to start service php7.1-fpm: Job for php7.1-fpm.service failed because the control process exited with error code. See “systemctl status php7.1-fpm.service” and “journalctl -xe” for details.\n”}

I’ve sshed into vagrant and ran systemctl status php7.1-fpm.service

got:

● php7.1-fpm.service - The PHP 7.1 FastCGI Process Manager
Loaded: loaded (/lib/systemd/system/php7.1-fpm.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2018-05-09 03:19:36 UTC; 21min ago
Docs: man:php-fpm7.1(8)
Process: 9529 ExecReload=/bin/kill -USR2 $MAINPID (code=exited, status=0/SUCCESS)
Main PID: 10079 (php-fpm7.1)
Status: “Processes active: 0, idle: 1, Requests: 0, slow: 0, Traffic: 0req/sec”
Tasks: 2
Memory: 8.9M
CPU: 83ms
CGroup: /system.slice/php7.1-fpm.service
├─10079 php-fpm: master process (/etc/php/7.1/fpm/php-fpm.conf)
└─10082 php-fpm: pool wordpress

Any thoughts?

There are several threads dealing with this error: https://discourse.roots.io/search?q=php7.1-fpm.service Have you tried any of the solutions or troubleshooting steps mentioned in those threads?

I have tried those theads. I am not sure if trellis is asking for a different version of php (maybe 7.2?). I’m really not sure what the issue is.

I sshed into my ubuntu server. it is running php7.2. Could this be the issue?