Plugin updates not shown in admin

Not sure if this is a bedrock issue, or a composer one, or something else. Basically on my admin pages for my sites I do not see when any plugin updates are available. I do my updates via composer and that all works fine, but I usually just glance at the backend to see if any updates have been released. In my development site (trellis) it works fine, but on my staging and production sites I do not see any update messages. Before I really dig into figuring it out I want to make sure this is not some behavior associated with disabling auto updates or some other configuration setting in Bedrock.

I also have disabled WP-Cron and running a linux cron task as suggested. It looks like this:

*/5 * * * * curl https://STAGINGSERVER/wp/wp-cron.php > /dev/null 2>&1

Looks okay to me but maybe it is not kicking off the update check?


define('DISALLOW_FILE_MODS', false);

Put that into your config.

Tried that. No change.

Have you tried running these steps? I’ve found it clears a lot of issues with this sort of thing:

  1. Delete site/vendor/composer/installed.json
  2. Delete site/composer.lock
  3. Go to Composer, run: cd ~/sites/project-name/site
  4. Run: composer clear-cache and rm -rf ~/.composer/cache
  5. Run: composer install

In case anyone is still running into the same problem as @alex_ciarlillo:

It seems that contrary to bedrock’s documentation (, the application configurations is taking precedence over the environment configurations (or at least in the case of 'DISALLOW_FILE_MODS').

Make sure that'DISALLOW_FILE_MODS', is also set to false in the application.php of your config.

This is by design on non-development environments.