Problem with cache busting - asset_path not printing asset versions

Hey all,
Long time Roots user, I have deployed several Sage 9 sites successfully.
Having an annoying time this morning trying to stage a site in progress.
Vagrant is working fine.

Server is DO droplet, 16.04.
On provision, Ansible complained that I needed to:

`sudo pip install passlib`

which I did, no problem. I figure this was because I recently upgraded Ansible.

Then Provision worked without error.
Deploy worked, also without error. I imported the DB, copied plugins and uploads.
The admin is fine, and the front of the site loads the content, but is missing styles and scripts. I get 404s for the scripts and styles because I am now missing the hashes. Is this an issue with passlib, or have I not configured the asset hashing correctly?
Maybe my brain is just not working correctly.

Apologies in advance if I’ve left out some crucial info for an assist.
What was I even doing before I found the Roots stack?

You have to transfer the built artifacts of your sage theme, too, you can use a hook for this:

Hmm, I have the build-before.yml file un-commented and my theme folder replacing ‘sage’.
So, not sure that’s the issue. Is that what you meant?
Thank you


Are the theme files versioned? Are the theme files really on the target server?

Yes, I have confirmed Versioned assets are in the dist directory on the server, as expected.

I should also mention, I am using Sage 9 beta2