Problems downgrading Ansible

Somehow I appear to be using Ansible 2.6.3 and I believe Trellis only supports up to Having this higher version looks like it’s giving me weird provisioning errors so I do need to get it back down again.

I’ve tried…

brew switch ansible

and I get

Error: ansible does not have a version “” in the Cellar.

and I’ve tried

brew install ansible

and I get

Error: No available formula with the name “”
==> Searching for a previously deleted formula (in the last month)…
Warning: homebrew/core is shallow clone. To get complete history run:
git -C “$(brew --repo homebrew/core)” fetch --unshallow
Error: No previously deleted formula found.
==> Searching for similarly named formulae…
Error: No similarly named formulae found.
==> Searching taps…
==> Searching taps on GitHub…
Error: No formulae found in taps.

Any ideas? I’m still a bit of a newbie with this stuff!

I’d recommend using pip to install Ansible, not Homebrew.


That’s exactly what I ended up doing. Uninstalled with Brew and reinstalled with pip, which seems to work!