Provisioning production fails : no "Release file"

The culprit seems to be /trellis/roles/mariadb/defaults/main.yml. I removed the [arch=amd64] tag like in commit 32b1b6fcec8cb9fe14c6ec43cc1fccd3851fac2f just to see if that did anything but it didn’t.

Actually, so it turns out that the provisioning problem and the deploy playbook problem were unrelated. Still having issues with that mariadb mirror seemingly standing in the way of provisioning but the other stuff was just… a <? tag that should have been a <?php tag instead. :man_facepalming:t2:

Same issue here. I think I provisioned successfully a couple weeks ago, so this seems to be a recent issue.

Running into the same issue since a few hours ago, I had run a successful provision as recent as yesterday.

Thinking it could be something to do with the DigitalOcean mirror for MariaDB?

Chatter on MariaDB Zulipchat seems to indicate it may be an upstream issue on MariaDB’s mirrors.

The way I managed to solve this was replacing with in trellis/roles/mariadb/defaults/main.yml.

It shouldn’t be considered a long-term solution, but at least it did the trick for the time being.

Same issue. I used, which was used before: Add MariaDB 10.2 PPA · roots/trellis@9d1bdad · GitHub

I tried changing the URL but the provision keeps calling the DigitalOcean link.

It seems like the mirror is cached somewhere, change it to any of the proposed mirrors won’t resolve the error for me.

This worked for me:

Change the url:

SSH into the guest machine:

$ trellis ssh development

In the guest machine:

List of all repositories (just to check)

$ grep ^ /etc/apt/sources.list /etc/apt/sources.list.d/*

Go to directory:
$ cd /etc/apt/sources.list.d

Delete the file:
$ sudo rm nyc2_mirrors_digitalocean_com_mariadb_repo_10_5_ubuntu.list

From host machine (trellis folder):
$ vagrant provision


apt-get update should generally clear the sources cache.

Now I’m wondering if we should move from Digitalocean as the default mirror though. I think this is the second time they’ve had issues.

We’ve released a new version of Trellis to address this by changing the mirror of the MariaDB repo: Release v1.9.1 · roots/trellis · GitHub


Just encountered this issue.

The PR fixes the apt source, however, running the playbook will still terminate with an ansible error as apt is apparently updated first (task Update apt packages somewhere before task Add MariaDB PPA that fixes the apt source).

New version: Thats perfect! :+1:

Does reprovisioning fix the issue directly on an existing Trellis system?
I had to manually remove the sources and then reprovision, as an apt upate caused ansible to fail before changing the source.

This topic was automatically closed after 42 days. New replies are no longer allowed.

I’m not sure if this is a temporary hiccup or not, but this issue resurfaced for me this evening. I was able to get things running by using the Rackspace mirror:

See 🔧 Change MariaDB PPA mirror to Rackspace by retlehs · Pull Request #1422 · roots/trellis · GitHub


Same issue here, so will roll with the solution you’ve given, thanks :slight_smile:

I’m having the same issue and the given fix (changing MariaDB mirror to Rackspace and removing the old “.list” file) has worked for me.

But since my mariadb_ppa link looks like this “” and the fix suggests to use “Index of /mariadb/repo/10.5/ubuntu” I was wondering if the version mismatch in the links (“repo/10.2” and “repo/10.5”) could cause any future troubles?

Thanks in advance and also thanks a lot for the fix!

It could, but you can update the mirror domain while keeping the version number the same.