Provisioning staging server returns error on installing mariadb-client

Hello,

When provisioning the server for staging , it returns this error on trying to install mariadb installation process returning a fatal error.

My Vagrant version is: 1.9.1

$ vagrant -v
Vagrant 1.9.1


TASK [mariadb : Install MySQL client] ******************************************

System info:
Ansible 2.2.0.0; Linux
Trellis at “Add Vagrant config”

‘/usr/bin/apt-get -y -o “Dpkg::Options::=–force-confdef” -o “Dpkg::Options
::=–force-confold” install ‘mariadb-client’’ failed: E: Unable to
correct problems, you have held broken packages.


Further output on log

fatal: [server_name]: FAILED! => {
“cache_update_time”: 1509212180,
“cache_updated”: false,
“changed”: false,
“failed”: true,
“invocation”: {
“module_args”: {
“allow_unauthenticated”: false,
“autoremove”: false,
“cache_valid_time”: 3600,
“deb”: null,
“default_release”: null,
“dpkg_options”: “force-confdef,force-confold”,
“force”: false,
“install_recommends”: null,
“name”: “mariadb-client”,
“only_upgrade”: false,
“package”: [
“mariadb-client”
],
“purge”: false,
“state”: “present”,
“update_cache”: true,
“upgrade”: null
},
“module_name”: “apt”
},
“stdout”: “Reading package lists…\nBuilding dependency tree…\nReading state information…\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n mariadb-client : Depends: mariadb-client-10.0 (>= 10.0.31-0ubuntu0.16.04.2) but it is not going to be installed\n”,
“stdout_lines”: [
“Reading package lists…”,
“Building dependency tree…”,
“Reading state information…”,
“Some packages could not be installed. This may mean that you have”,
“requested an impossible situation or if you are using the unstable”,
“distribution that some required packages have not yet been created”,
“or been moved out of Incoming.”,
“The following information may help to resolve the situation:”,
"",
“The following packages have unmet dependencies:”,
" mariadb-client : Depends: mariadb-client-10.0 (>= 10.0.31-0ubuntu0.16.04.2) but it is not going to be installed"
]
}

Is this due to Vagrant incompatibility? On the reqs it shows >=1.8.5

Thanks

Testing with the latest Vagrant, Vagrant 1.8.1 , Vagrant 1.8.6 doesn’t work at all for me so I’m thinking it could possibly be the provisioning of the staging server itself on DigitalOcean? I’m using DigitalOcean LEMP on 16.04

Thanks

1 Like

Agreed. I don’t think it’s a Vagrant issue. In the “Choose an image” step of creating a DigitalOcean droplet, rather than using the DigitalOcean one-click app for “LEMP on 16.04”, choose “Distributions > Ubuntu 16.04.3 x 64”. That way Trellis can use its own process to instal the “EMP” portion of the desired LEMP stack. Notice relevant roles in the Trellis server.yml playbook.

I think it’s totally natural to have figured the one-click app for the LEMP stack was the best choice. However, the docs do mention…

You need a server running a bare/stock version of Ubuntu 16.04 Xenial. If you’re using a host such as DigitalOcean, then just select their Ubuntu 16.04 option.

4 Likes

Yep that worked perfectly for me, choosing Ubuntu 16.04.3 x64 works great and mariadb installs smoothly.

1 Like