Running multiple instances of Trellis

I’m currently on Windows (using Babun) and I tend to have an issue getting Trellis to run multiple instances at a time.

It seems to get stuck on either installing ansible / galaxy during the initial vagrant provision or stuck on mounting NFS shared folders.

Is there a possible fix when using VirtualBox?

I run everything out of D:/Development/sitename or when using Babun, through my symlink ~/dev/sitename.

I have 1 instance of Trellis running right now. Here is what happens when I attempt to start an already provisioned Trellis:

Here is what happens when I attempt to vagrant up a fresh Trellis instance:

The “running ansible-galaxy” has been like that for like 3 days right now as I’ve just had it minimized while working on a couple other things. No errors or anything, simply just stuck.

Both are using the latest version of Trellis off GitHub with the latest version of VirtualBox.

I’m using Vagrant 1.8.7 since when attempting to upgrade Vagrant it seemed multiple plugins have a fair share of issues right now. Not sure if it’s been fixed since my last go at it.

Quick question: have you manually edited the Vagrant IP? By default Trellis hard codes the internal IP so to run multiple VMs simultaneously you need to manually select different IPs.

1 Like

Ah that could be it. Let me configure that on all of my currently planned Trellis’ and get back to you. Also updated my original post as you posted this with a screenshot of NFS shared folders failing.

Appears the VirtualBox NFS shares still doesn’t want to play nice after changing the IP’s in the Vagrantfile’s.


It appears it’s still attempting to mount -o on despite them all being changed in the corresponding Vagrantfile's – although not sure if that’s still correct since it’d be .5 if it was still using the default.

1 Like

Well, it appears to be working now after rebooting despite killing all of the services in ProcessExplorer.

Daily reminder that no matter how optimized and configured your Windows environment is, it’s still a piece of crap.

Thanks for the help!

1 Like