Roots Discourse

Running Sage 9.x on Azure Web Services...?

Heyo,

I’m not holding out a lot of hope on this one, but I’m wondering if anyone has had any success running a Sage 9.x based theme on Azure Web Services?

We recently developed a custom site for a client under the assumption that it would be run on a Linux VM, and the site runs just great (as expected) in that environment. Now the client is pushing hard to move hosting over to Azure Web Services, and we’re having no end of issues trying to get it to even function correctly.

Specifically, most (but not all) of the pages on the test site we’ve got on Azure are blowing up with what I assume are Blade errors, eg: Uncaught InvalidArgumentException: Cannot end a section without first starting one.…My assumption with that issue is that this is a composer runtime issue, potentially?

If anyone has any experience/insight with getting Sage 9.x to play nice on Azure, I’d really appreciate hearing what you did to get it working :slight_smile:

Many thanks in advance!

You probably already tried this - but have you also cleared the uploads/cache directory? Because there Blade caches to PHP files that are used for improving performance.

Yeah, sadly that was my first suspicion, and the first thing we tried. Thought it must’ve been a permissions error (ie. app not being able to read/write to uploads/cache, but that wasn’t fruitful unfortunately :frowning:

So the particular error indicates that a @section wasn’t closed with @endsection.


According to that issue discussion Blade template engine has this new, stricter requirement for some time.
Sage uses its own standalone Blade implementation and at some point may have introduced it.

Are you sure the composer lockfiles for the Sage (theme runtime) are the same on a system where it works and on the Azure system where it doesn’t?
Then check out such a particular PHP file (rendered Blade in cache directory), any PHP includes there that fail?