Roots Discourse

Sage 9 Beta 2, Browsersync + Local https

Fresh Sage install, I use https locally on my dev sites and then trust the certificate. But the setup process puts the following into config.json, which makes Browsersync not work (won’t refresh changes on save) because of the http/s mismatch.

"devUrl": "https://example.dev",
"proxyUrl": "http://localhost:3000",

Adding https to the proxyUrl fixes the issue:

Fixed:

"devUrl": "https://example.dev",
"proxyUrl": "https://localhost:3000",
1 Like

Thanks, @Simeon!

Once you have made these changes, how do you make the BrowserSync control page work (https://localhost:3001/)?

BrowserSync has a setting for this.

I added the https: true setting to resources/assets/build/webpack.config.watch.js.

new BrowserSyncPlugin({
   ...
   https: true,
   ...

However, this doesn’t seem to work for me.

Yeah I just don’t use https in dev anymore. Way too much hassle.

1 Like

Thanks for sharing that. Makes sense! :grin: