Sage 9 Beta 4 Foundation 6.4 JS issues




This is my first post so hopefully I am clear about my issue. I have used Sage in the past so am very excited about the newest versions when they are released. So I wanted to give Sage 9 a try for a client’s new site. We have used Foundation quite a bit so happy to see that I could choose that framework during installation.

Everything had gone as planned until I started building the “Responsive Navigation” today and I realized that when I run “yarn start build” that my changes looked proper, but when I ran “yarn run start” that my navigation was acting like there was no Foundation Javascript. After verifying that the Foundation Javascript was in the main.js I went down a few other trails, but came up empty.

I am hoping someone else has encountered this or can point me in the right direction. Thanks!


@Chris_Costanza I’m having the same problem. Did you find a solution?



I am using Node “7.10.0” which comes with a warning that it’s not supported and may encounter bugs or unexpected behaviour. Could this be the issue?