Sage 9 compatibility with PHP8 (illuminate)


I encountered a problem with Sage 9 as described here when trying to update the server to PHP8:

I went back to PHP7.4, so the issue is not urgent, but I also noticed that at least one Wordpress plugin (User Role Editor, 700000+ installs) requires PHP7.4 and this change happened quite recently. The support for php7.3 ended in the end of last year, so maybe they updated their minimum requirement, or maybe they actually have something that does not work with PHP7.3. Any case, my question is:

What happens when PHP7.4 support ends in the end of this year and it would be prudent to update to PHP8.0. What is the recommended course of action? We have multiple sites using Sage 9 and I would expect some plugins to start requiring PHP8.0 at some point during this year or latest in the beginning of the next one. Is there going to be update in Sage 9? Or should we change to Sage 10 (there is multiple separate projects, so is this a big task)? I saw in the post above that someone has been using Sage since 8, how they have resolved this issue?

If you’re looking to use Sage 9 with newer versions of Laravel that support newer versions of PHP, you’d want to:

  1. Fork GitHub - roots/sage-lib: Library files for Sage 9
  2. Bump the Laravel dependencies to new versions
  3. Update the sage-lib functionality as necessary to be compatible with any changes after upgrading Laravel

Sage 8 is not affected since it doesn’t include PHP dependencies. Sage 9 was the first release with Blade support, which requires the illuminate/support dependency.

OK thanks! And I wonder if anyone has already done this and know how much changes to the functionalities are required to get it working?

There’s some PR’s on the repo you can reference but no one has attempted it for the latest version

This topic was automatically closed after 42 days. New replies are no longer allowed.