Sage 9 Yarn Run Start compiles but hangs in browser

I have successfully installed Trellis, Bedrock and Sage without any errors. I have also reinstalled all the software dependencies to better than what is recommended. (EG: Yarn, Node, etc…). When I run yarn run start after running yarn and yarn build I get this: `beaglejuice:villageonwhitehead todd$ yarn run start
yarn run v1.5.1
$ webpack --hide-modules --watch --config resources/assets/build/webpack.config.js

Webpack is watching the files…

DONE Compiled successfully in 1197ms 09:58:28

[BS] [HTML Injector] Running…
[Browsersync] Proxying: http://villageonwhitehead.test
[Browsersync] Access URLs:

   Local: http://localhost:3002

      UI: http://localhost:3003

UI External:

[Browsersync] Watching files…

DONE Compiled successfully in 719ms `

It then opens up a tab in Chrome http://localhost:3002/ and hangs. vagrant up works fine and I can see it in VirtualBox. Do you have any idea what the issue is? I also have several Roots 8.5 running on the same machine.

Does http://villageonwhitehead.test load?

It does not. Actually that url does not hang it just says that no data was returned.

Then the problem is with your virtual machine, not yarn. I’d try some of the following:

I can get browsersync page to come up but not the site. So if I change localhost:3003 I get

I have done all the things you suggested as well as remove the host entries and do vagrant up again and still the same issues.

The interface at localhost:3003 is created by Browsersync; it has nothing to do with your VM.

Can you access your site by going directly to the IP for your VM?

I cannot access it by IP. I started over again and now I am getting this error:

==> default: Running provisioner: ansible…
default: Running ansible-galaxy…

  • downloading role ‘composer’, owned by geerlingguy
  • downloading role from
    [ERROR]: failed to download the file: Failed to validate the SSL certificate
    for Make sure your managed systems have a valid CA certificate
    installed. You can use validate_certs=False if you do not need to confirm the
    servers identity but this is unsafe and not recommended. Paths checked for this
    platform: /etc/ssl/certs, /etc/ansible, /usr/local/etc/openssl. The exception
    msg was: [SSL: TLSV1_ALERT_PROTOCOL_VERSION] tlsv1 alert protocol version

[WARNING]: - composer was NOT installed successfully.

ERROR! - you can use --ignore-errors to skip failed roles and finish processing the list.
Ansible failed to complete successfully. Any error output should be
visible above. Please fix these errors and try again.

I just updated my OpenSSL via brew:
Pouring openssl-1.0.2n.high_sierra.bottle.tar.gz

You’re liking running into this error: Github and new Cryptographic Standard

It appears that I have 2 versions of python installed. 2 and 3 but when I follow the instructions in the link to the discourse above I can’t seem to get rid of version 3. I have tried everything on stack exchange and when I run brew install python I get a response that I have 3.6.4_4 installed. Any idea how to completely wipe out pytone and start new?