Sage fails on first "yarn" command

I’ trying to install Sage on a Bedrock installation. But after I’ve cloned Sage, and type “yarn”, I get this error.

yarn install v0.27.5
[1/4] Resolving packages…
[2/4] Fetching packages…
error webpack@4.6.0: The engine “node” is incompatible with this module. Expected version “>=6.11.5”.
error Found incompatible module
info Visit for documentation about this command.

I tried to upgrade Node.js but it didn’t help. What should I try next? Downgrade something?

Did you upgrade Webpack? Sage is still on Webpack 3.10. Also, make sure you’re not on Node 10 as Sage doesn’t support it yet. You can use something like nvm to manage multiple Node versions.

But from the looks of it, it seems like you were running a much older version of Node. I would really recommend installing nvm and using that to manage your Node version. Node 9.x or the current LTS would be a healthy default (set with nvm alias default [version]).

Thanks a lot. It worked.
I uninstalled webpack and re-installed the specific version.
Then I installed nvm and ran nvm install node.
When I got back to my theme directory, it worked when I ran yarn :slight_smile:

1 Like