Sage not including Bower dependencies

Hello there,

So I am really new to SAGE, was trying to learn to use it by doing a new client’s project. I guess I’ll go with my former development work flow for now, but I’d like to get some light into this issue moving forward.

I have just created a new host from MAMP Pro which is what I use, I know you recommend Trellis or VVV but right now I wanna go 1 step at a time so I’d like to continue using MAMP.
My site works as expected when visiting my www.example.loc/
With a fresh wordpress and sage installations I included bourbon and fontawesome with bower, I can see the folders in the bower_components/ folder. I also see in their bower.json files the correct “main” assets being included.
I have ran gulp, gulp watch, gulp styles, and gulp && gulp watch but none seem to be including the dependencies into my main bower.json file (and it’s not included in the wiredep dependencies in main.scss either). Both still only have the bootstrap dependency included.

Also, when I type in gulp watch the browsersync will open up my www.example.loc/ and I will have to reload the page to watch changes on the code, instead of localhost:3000 and sync my changes automatically.

Any help would be highly appreciated. I looked at some similar issues, tried deleting the hosts from my hosts file (like recommended when using MAMP on other post) and redoing them but that didn’t work out for me. I should probably point out that browsersync was working out for me last week, only change I’ve done is including some paths to my mysql sockets and composer in my user profile bash file (for a different project on drupal that uses drush so I had to make it work). I tried to revert those changes just for trying out but didn’t work either.

I just managed to include the dependencies by using the --save flag when installing the dependencies.
My ONLY issue remaining for now is with the gulp watch not listening to localhost:3000 and not browsersync’ing. My manifest.json file has

"config": {
    "devUrl": "http://example.loc"

What does terminal output when you first run gulp watch? Have you visited the UI address for BrowserSync and tried troubleshooting the issue yourself at all?

What does terminal output when you actually have the watch task running and you make a change in a watched file?

Have you made any changes to the wiredep block in your stylesheet?

I know this isn’t immediately helpful, and you’re not looking for recommendations, but I really think you’ll actually have an easier time if you just make the switch to one of the Vagrant variants.

VVV is a great intro, IMHO, and once you’re comfortable, then give Trellis a try. I did an up and running type thing on VVV here, and a series on Trellis here, if it’s helpful.

When I run gulp watch the terminal seems to manage it fine and completes the process detecting which file has changed, and I haven’t edited the wiredep block manually if that’s what you mean.

The problem is not so much with the watch itself as with the browser sync I think…

The only way I can access my site and have it update automatically is when I access the site through the external URL with the ip listening to port 3000. But when I run gulp watch it tries to open it through localhost:3000 which just redirects to http://example.loc/ and doesn’t sync.

Is this helpful?

So this was working fine until a few minutes ago… I added the script quoted above to base.php to no avail.

I had like 4 sites running on SAGE locally yesterday and they were all working just fine.
Made a new install today, updated the manifest.json with the correct devUrl and setup a few bower dependencies etc, then tried to run gulp && gulp watch but back to the same old problem:

The watching of the files works, it’s the localhost:3000 that redirects to example.loc/

When I try to run the gulp watch on any of the older projects (where it was working just fine - say another-example.loc), it will still try to open the new example.loc that doesn’t listen to :3000…

Any ideas? This is starting to really bug me cause I dont get it, Im aware its a browsersync thing though

Hello, Cato him also new to SEGA as will and having the same problem what was the script quoted that you add above base.php

Hey there @brandonpowell, as far as bower including goes all I had to do was include the --save flag as noted in another thread by someone else.
bower install --save bourbon