Sage9, webpack always copies and optimizes images/fonts which leads to a huge build time

Can’t we do anything about already copied/optmized assets such as the fonts and images? My build constantly repeats that process and the total build time is now at 3 minutes.

Also, I always get the following warning for multiple files:

WARNING in asset size limit: The following asset(s) exceed the recommended size limit (250 kB).
This can impact web performance.
  fonts/MY_FONT/TTF/MY_FONT_79e0c29cff90ef22bd513f10253b1b32.ttf (270 kB)

You have two main options:

  1. Move the assets to Webpack externals:

  2. Use the file-loader instead of the url-loader and just copy the files to the correct folder. Something like what’s shown here:

A start should also only build the changed assets, not the whole set of assets, so if you’re working with styles it won’t build images and vice versa.

Sorry, I wasn’t being specific. This only happens on build tasks.