Site Completely Breaks With Latest Version - Blank Page

Wordpress: 3.8.1
Roots.io: 6.5.2
Server: lighttpd/1.4.28

Fresh installs all round.

As soon as I activated the theme everything went white, no url would return anything.

When I edit wp-config.php and set define('WP_DEBUG', true); I get the following error:

Notice: ob_end_flush(): failed to delete buffer zlib output compression in /pathtosite/dev/wp-includes/functions.php on line 2773

Deleted all plugins and all copies of themes trying to restore the blog but nothing will stop it displaying that simple error.

If I access /wp-admin/install.php it says I can’t reinstall because the database tables exist and also has the error above at the end of the box. Same with upgrade.php.

I have another theme best on Roots 6.5.1 which worked fine in this environment but it seems the latest fails catastrophically.

Any thoughts?

Is this related to Roots? Do the default themes work?

Googled your error and came across this: https://core.trac.wordpress.org/ticket/18525

Ben

Thanks for your reply. It was a fresh install of Wordpress and working fine.

I tried out the older version of Roots like I described at first and it was fully operational.

Then I uploaded a fresh copy of the latest Roots release (6.5.2) to get started on a fresh project and then nothing worked any more. As soon as I pressed activate on the theme page it refreshed and the screen was empty. All urls give back the ob_end_flush() error I described above.

My suspicion was that it is because the server is lighttpd which is why I put it in the report above.

I was just hoping that somebody more experienced might have an idea as to why its not working.

Actually one other note that might make some sense of this all - I seem to have had a mid-release version as my changelog for the old version that works doesn’t mention the url rewrites being moved to a plugin but looking at the changelog for 6.5.1 is has two entries in it.