Roots Discourse

Some css classes missing on build:production

When I run build:production there are no errors but some css classes are missing.

I’m using a custom tachyons setup for styles (nothing out of the ordinary, jut extended to have a couple more breakpoints) and also use BEM handled with mixins as documented here: https://medium.com/@marcmintel/pushing-bem-to-the-next-level-with-sass-3-4-5239d2371321.

I mention the BEM setup as I saw this issue with Bootstrap (https://github.com/roots/sage/issues/2017#issuecomment-361054297) and wondered if it might be related, but I’m not sure what steps to take to debug.

Follow the bootstrap solution. I faced it many times. Just add two variables for bootstrap toggle button in your variables list and try…

If face same issue, please check your main_###.css to get more idea from where your css breaks.

Thanks for the reply!

I did follow the bootstrap solution as much as I could, but I’m not using bootstrap so I assume the actual problem is different. I don’t have any str-replace() in my sass, which is an error causing problem referenced in the post linked above.

I also tried: Set parser: undefined in the postcss.config.js file as described in the post, but I did not see any errors or information when running build:production.

I have looked at my main_###.css file but it’s not clear where there is an error. Some classes exist, some don’t. :grimacing:

Do you know how I can I identify where the problem is??

Thanks

“Fixed” this today, still no idea what went wrong. I setup a new site, copied each assets file over one by one, testing :production each time. Got to the end and everything worked so I just copied the whole assets folder over and everything’s good.

Okay.

Enjoy :slight_smile:

This topic was automatically closed after 42 days. New replies are no longer allowed.