SSH Error: data could not be sent to remote host "". Make sure this host can be reached over ssh

I apologize for the two quick posts that are related.

I executed ./bin/ staging and I get this error: SSH Error: data could not be sent to remote host "". Make sure this host can be reached over ssh

However, this is a fresh DO Droplet, and I am able to ssh - and I cleared my /.ssh/known_hosts file.

These are the only solutions I’ve seen in a variety of posts here and in general searches on Google and I have no more leads on where to look for solutions.

I’m willing to pay for someones time to educate me on this. Thank you.

I feel silly for asking, but you provisioned first, right?


I’m sorry, can you remind me what provisioned is? vagrant up?

It’s all explained in the docs:

You have to provision the remote server before you can start deploying to it.


Thank you. I overlooked this step.

I’m embarrassed but grateful for your help.

Actually, this is occurring on a second site I have that is already provisioned.

@kalenjohnson would you be willing to relist this as it appears the provisioning is not the issue in this case?

If you’re seeing an error with, that would suggest that you have not set up the group_vars for that environment, as would instead be your site key. If the error is in fact different, could you post it up?

By “could you post it up” did you mean my group_vars/{environment}/vault.yml?

In the case of Site #1, it is complete and been published for some time. The same day I began getting this error for Site #2 I seemingly suddenly started to get it for Site #1 as well. And I don’t recall making any changes to my group_vars for Site #1.

PS Thanks @kalenjohnson

No, please don’t post up your vault file!

What is the error you’re receiving? Or is it the exact same error message as in the first post?

Oh, haha, I would strip sensitive info from it if I did. :smiley:

But yes, at this point the error mentioned originally in this post is the error I get when I try to execute ./bin/ production on site #1, and `./bin/ staging". But we can focus on site 1 for now because I haven’t provisioned site 2’s staging area yet.

And your group_vars/env/wordpress_sites.yml definitely doesn’t have an key in there?

Correct. There are no references to and it correctly references the Production URL.

@ben would you be willing to explain why you unlisted this and consider re-listing it? I’m experience this on Mac and Linux machines and only when I run the deploy script for Trellis. So I’m not sure where else I would go to get support for this issue.

@ben I’m well aware I ask a lot of questions here, and that is a tax on everyone, but:

  1. I often offer to pay people for their time. And have.
  2. I contribute to other threads when and where I can.
  3. I’ve contributed to the docs.
  4. Every time I post a question I try to find a question I can answer. You, Phil, Scott and Kalen have almost always answered before I can reply (at least to the few questions I’m capable of answering). Literally within minutes of it being posted.
  5. I’ve only deployed one site with the Roots stack so far and the other two sites I’m actively working on have been plagued with obstacle after obstacle. So I’ve yet to actually deploy a site without issues - thus know I’ve learned how to use it correctly and therefore be able to help others.

I am at your mercy. I am willing to do what’s necessary to become a valuable member of the community. But I cannot do it if I cannot get my questions answered in the early days of learning this system.

Does ssh work? Does your site folder exist in /srv/www?