SSH Putty Fatal Error when logging into VM


I just downloaded the newest version of Trellis, and I have configured it using

When I run ‘vagrant up’ all of the processes complete as they should.

However, I am having an issue using SSH. When I attempt to log into the VM with Putty, I get the following error:

Putty Fatal Error:
Disconnected: No supported authentication methods available (server sent: publickey )

I am not sure what I did wrong with this setup, I have a slightly older version of trellis and ssh works.

Any ideas?

I’m not too familiar with Putty. The suggested way to SSH into a vagrant box is to use vagrant ssh. Can you do that with Putty?

You could also try destroying and up-ing the box again.

And if it still doesn’t work, you might run vagrant ssh-config and double-check that those configs match the options you’ve given PuTTY.

If problems persist, you could let us know where you are in applying PuTTY-with-Vagrant suggestions like this, this, and this. Those are just a few google results that came up for me. I can’t vouch for them in particular.

Thank you so much for your hlep!

You got me on the right track.

I am on a Windows 8.1 machine so ‘vagrant ssh’ does not work out of the box. But after trying that command, the path to the private key was revealed to me.

I’ve been able to log in the VM without an SSH key in the past, but maybe something has been updated that makes SSH with a key mandatory, and the Putty client fails because it does not know the path?

I followed the instructions here, and now it works

"An SSH client is generally not distributed with Windows by default. Because of this, if you are on Windows, Vagrant will instead output SSH authentication info which you can use with your favorite SSH client, such as PuTTY.

PuTTY may not recognize the insecure_private_key provided by vagrant as a valid private key. To remedy this, first grab the PuTTYgen app. Then use PuTTYgen and import the insecure_private_key (found in the .vagrant.d dir in your home directory) and save a ppk file from that private key. Use the ppk file instead of the default one when SSHing into your vagrant box."


Nice work, and thanks for reporting your fix! That helps everybody.

I appreciate the quick help!