Ssl3_read_bytes:tlsv1 unrecognized name downloading {domain}/satispress/packages.json

The /etc/hosts file should have been updated by hostnamectl set-hostname.

The /etc/hosts file should begin like this: localhost

When I run hostname I get

/etc/hosts must also be adjusted as above (if this wasn’t done by the hostnamectl tool).

The line alliancechemical
is wrong, it should be web-1 (the subdomain should suffice).

If the tool didn’t change it, you can edit it manually.

Yaaa!! After applying the hosts edit. I can curl and I get the expected response.

Going to try to redeploy now.

Everything worked! Appreciate your patience @strarsis. I marked your solution hopefully it helps someone else too.

After some testing with the Ubuntu setup I noticed that the default Ubuntu server setup doesn’t allow a domain, rather just a hostname.

I try to find out how this issue can arise, so it can be warned about in the Trellis docs.
How have you installed that Ubuntu instance? A base image from Digital Ocean, its setup assistant?
You specified a complete domain, not just a hostname?

I followed this guide when setting up my server on DO

When it asked for droplet name that’s where I named it

1 Like

I created a new issue for adding a warning about this to the Trellis docs: