Start simple new project fails

I’m trying to get Trellis working in a new Catalina machine. First tried with existing project, then starting from sctartch with trellis-cli and finally with the most simple way, cloning trellis and bedrock with composer.

Python 3.8.2

With ansible 2.8.11 I get this error at vagrant up:

TASK [wordpress-install : Copy .env file into web root] ************************
System info:
  Ansible 2.8.11; Vagrant 2.2.9; Darwin
  Trellis version (per changelog): "Removes ID from Lets Encrypt bundled certificate and make filename stable"
Unexpected failure during module execution.
An exception occurred during task execution. To see the full traceback, use -vvv. The error was: AttributeError: 'VariableManager' object has no attribute '_loader'
fatal: [default]: FAILED! => {"stdout": ""}

With ansible 2.9 (supported by latest Trellis) I get this error at vagrant up:

TASK [python_interpreter : Get Ubuntu release] *********************************
to see the full traceback, use -vvv
ERROR! Unexpected Exception, this is probably a bug: cannot pickle 'module' object
Ansible failed to complete successfully. Any error output should be
visible above. Please fix these errors and try again.

Tried several times with same results. What’s going on? Thanks!

Solved! with @slowrush miniguide:

1 Like

This topic was automatically closed after 42 days. New replies are no longer allowed.