Roots Discourse

.test site unreachable on existing projects

Hey there, I’m new to Trellis and have been having a pretty inconsistent experience getting projects set up.

Using Trellis CLI, setting up new projects is very easy and works as it should. But when I clone existing projects, I run into issues.

For example, I have two computers. On one, I create a new Trellis site using ‘trellis new xxx.com’ and it works great. I commit all of this to a Git repo, the clone it to the other computer.

After copying over the .vault_pass and installing all of the composer dependencies, I start up vagrant with ‘trellis up’. From the command line, everything looks right, but when I try to load ‘xxx.test’, I’m unable to connect.

I’ve also checked VirtualBox and the domain appears to be running as it should.

What am I missing?

Have you checked your hosts file on the second computer? Unless it’s been told to look for xxx.test on your VM’s IP, it won’t be able to connect.

I have and it’s indeed in there. The IP matches other .test sites that work properly too.

What does your development environment look like, i.e. OS, etc? Are either computers running any other software that manages/messes w/ DNS resolution?

iMac and MBP, both up-to-date.

I have DesktopServer and Docker installed. I haven’t used Docker in a while and DesktopServer fairly infrequently. I do notice there’s some issues between Vagrant and Desktop server if they’re both going (dropping connection, etc), so I’ll typically restart and use only one during a session.

I guess the weird thing is that sites (in Trellis) on either computer work fine, but if they’re cloned from another, they fail to load.

Unfortunately I don’t have any experience w/ trellis-cli so I can’t help you much there. :frowning:

This

makes it sound to me like you

  • aren’t including something in your repo that you should
  • are including something in your repo that you shouldn’t

But I have no idea what that might be. :confused:

Have you tried changing the IP in vagrant.default.yml and running vagrant destroy + vagrant up?

yeah, I’m really stumped too. i’ve vagrant destroyed multiple times, but no luck.

I appreciate the help in any case!

This is just a guess, but make sure you’re only running one Trellis VM at a time. Having more than one running can cause the issue you’re seeing.

If you must run multiple trellis VMs in parallel, make sure each of them has unique vagrant_ip

1 Like

good call on the multiple VMs – I have a feeling that could have been part of the issue.

I’ve since restored my Mac, so we’ll see if it pops up again.

Solved it –

In addition to running composer install in /site, I also had to run trellis galaxy install

This topic was automatically closed after 42 days. New replies are no longer allowed.