Trellis 1.21.0 cannot finish installation

Hello, I’m having a problem with this new version 1.21.0 . I’m using Manjaro Linux, PHP 8.1, Vagrant 2.3.4, Python3, using trellis-cli. I can finish ‘trellis new’ but after ‘trellis up’ the vm begins installation and then the following error:

'E: Package 'linux-headers-5.15.0-67-generic' has no installation candidate
Unmounting Virtualbox Guest Additions ISO from: /mnt
umount: /mnt: not mounted.
==> default: Checking for guest additions in VM...
The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!

umount /mnt

Stdout from the command:

Stderr from the command:

umount: /mnt: not mounted.

exit status 1

All my others sites are fine but using a different version of Trellis.

Have you tried deleting the VM and trying again? Does the same error happen every time?

My guess is this is not related to Trellis 1.21.0. Not much changed in that release (see Release v1.21.0 · roots/trellis · GitHub)

There was one change related to Vagrant synced folders, but unless you’ve manually changed the mount type to be parallels, that change wouldn’t apply at all.

1 Like

Hi swalkinshaw, thank you for your response. It seems Vagrant was the culprit. So far I deleted the VM, initiated a new installation and nothing. I downgrade to 2.3.3 (after many downgrades tries from others apps) and now it’s working.

Thanks a lot!

1 Like