Trellis / Bedrock paths cached

I have a strange error, and I cannot find a way to solve it, running OSX 10.10

  1. I have installed trellis and bedrock into folder name ‘trellis’
  • everything went fine no problems
  1. I have decided I want a different setup, I would like to have a multisite so I can keep all of my client sites under same multisite installation.

  2. I have deleted the ‘trellis’ folder and I created a new one named ‘agency’ and I did a clean setup of WP multisite, trellis + bedrock.

Now, problem is that I get error that folder is missing ‘trellis/site’ (the one I have previously installed and deleted).
Strange thing, if I create that folder, and do ‘vagrant reload’ everything works fine.
If I delete folder and do ‘vagrant reload’ I get error, even if all my files and everything is now kept in other folder ‘agency’

  • I have tried to do search in all files to see if I forgot to change this in configuration files anywhere, but 0 match.
  • I have tried to clear caches everywhere I could (using onyx), restarted the os, no luck
  • I have even deleted composer, nodejs, npm and reinstalled everything, updated ruby gems, no luck

Anyone can suggest where should I look for this?
It’s like this path was cached somewhere and I cannot find a way to clear this.
Now everything works if folder is there, it’s empty, nothing there but it has to exist.

Thanks in advanced.

1 Like

Did you delete the Vagrant virtual machine?

Just do vagrant destroy and then vagrant up again. You can always delete the .vagrant directory as well to make sure it’s gone.

yes, I deleted it.
couple of times I have tried, I have destroyed and also I have deleted all boxes and downloaded them again.
Really strange, I don’t know where has this stuck

I’m a little confused about your directory structure based on how you’re describing it. Are you following GitHub - roots/roots-example-project.com: Example Roots stack project (Trellis, Bedrock, Sage)?

Because this sounds weird:

I have installed trellis and bedrock into folder name ‘trellis’
I have deleted the ‘trellis’ folder and I created a new one named ‘agency’

Hi Ben,

Yes, it is exact same structure

trellis

  • ansible
  • site

agency

  • ansible
  • site

I have googled this out, looks like it’s fine now.
What I got is error:

==> default: Mounting NFS shared folders...
==> default: Mounting shared folders...
    default: /vagrant => /Users/xyz/www/demo/ansible
==> default: Bindfs seems to not be installed on the virtual machine
    
NFS is reporting that your exports file is invalid. Vagrant does
this check before making any changes to the file. Please correct
the issues below and execute "vagrant reload":
    
exports:2: path contains non-directory or non-existent components: /Users/xyz/www/trellis/site
exports:2: no usable directories in export entry
exports:2: using fallback (marked offline): /

But i’v manage to find a solution that worked: http://philcollin.us/vagrant-error-nfs-is-reporting-that-your-exports-file-is-invalid/

I have just tested with new installation, working fine for now.
I was confused because path was always the same after I couple of times re-installed everything.

Cheers

1 Like

One more thing, just for the ref to others.
Maybe the first reason was I did not have exports file in /etc/exports
I have created it manually with sudo first

sudo touch /etc/exports
1 Like