Trellis, Sage Intallations for Windows OS


I need your help please.

I need to work on a WordPress Theme that has been made using Sage (I’ve been sent the .zip folder) and I’ve been trying to install and run Trellis and Sage in my Windows OS to create my local dev environment so I can work on this theme (I know I don’t need to use them together, but I’d like to), but I have run into too much bugs and problems. When I get a problem, I read everywhere to find a solution and I may solve it, but then another problem comes up, and so on. I’m running out of time and I’m spending it all trying to solve the problems installing Trellis and Sage in a Windows OS. The documentation regarding Windows installations in the Roots site is not well explained and the topics that I’ve found in the Roots discourse doesn’t cover all the installation process and it just gives you indications on how to solve some issues (that not always work or are not updated), but not all.

Where can I find an easy to follow, well explained and up to date document, article or tutorial, on how to install and run Trellis and Sage in a Windows OS and/or how to work on a WP Theme that has been made using Sage, if I don’t have Sage (which I don’t think is possible)?

Thank you for your help!

This is helpful:

Hey @pvargas,

For Trellis, a lot of it depends on what version of Windows you’re on–mostly, if you use WSL on Windows 10 or not.

Can you provide a little more info on your environment, and also where you currently are in the process and what’s not working?

For Sage:

I don’t 100% understand what you mean here. If you’re working on a theme that was made using Sage, then you have Sage–it’s part of the theme you’re working on. Does that make sense? If not, you’ll have to clarify.

Personally, if you’re under a deadline and having trouble getting Trellis working–and the client you’re working for doesn’t already use Trellis–I would set it aside for now and just get the job done. Set up a WordPress dev environment using whatever tool you’re most comfortable with and drop the Sage theme into that.

1 Like

Thank you @mmirus.

I’ve tried to drop the Sage theme into my local environment (I use XAMPP or Local by Flywheel), but I can’t view the site or the admin panel. It gives me a “Page not found” 404 error. How should I just drop the Sage theme into my local environment and be able to work on it?

That’s what I meant: I have the Sage theme (in the .zip folder that was provided to me), but it doesn’t work well if I just drop it in my local environment (XAMPP or Local by Flywheel), so I thought I may need to install Sage (by installing and running yarn, browsersync, composer, etc.) I installed all of these, but still doesn’t work, I cannot access to view the site or to enter to the admin panel (like I could do with any other theme made without using Sage)

This is unrelated to Sage. You need a working WordPress installation in order to use Sage. Installing Sage doesn’t break the WP admin or prevent you from accessing your local development environment.

If I use XAMPP or Local and install a new WordPress environment it works fine, as always.

Now that I’m trying to work with a theme made with Sage and try to use it in XAMPP or Local…it doesn’t work, so of course it’s related to Sage. Otherwise I’d be able to work with it as I always do on any other theme or WordPress installation.

My reply still stands

Ok. But you are not being helpful at all.

Of course I have a working WP installation, but it doesn’t work with a Sage theme. So my reply still stands also.

Why did you unlisted my question? You are not only being unhelpful but also damaging my attempt to look for help. What a great image you give for the Roots team.

You aren’t being helpful… and you’re looking for help from volunteers on something you’re getting paid to do.

Roots Discourse isn’t the place to learn about PHP debugging 101, you’re really going to have to demonstrate that you’ve truly tried to fix your issues rather than expecting a complete rundown on how to setup a local development environment, which has nothing to do with using Sage.

Listen. You are building a tool that is supposed to help and I guess Roots wants developers, designers and the community to adopt the tool (Sage and the other tools)…So in order for Roots to be able to accomplish this, Roots has to inform, teach and communicate everything that could help the community adopt and use the tool. This is business building 101.

This is the reason why Roots has invested in having a discourse web where everybody can look for help. It doesn’t matter if you are a junior a senior or just curious about the tool that Roots is developing. The Roots team should be able to dispel all doubts and build this community. This is brand and community building 101.

Don’t get me wrong, I think Sage is a great tool, but at the moment it’s relatively new and it is supposed to have several problems. I understand you get mad when somebody posts a problem and the best answer you can give is that “It’s not related to Sage”, but it is. I’ve been trying to solve this problem for 5 days, I saw many similar issues in this discourse without a good answer and with other Roots developers getting mad. The rest of the community on the other hand is very gentile and helpful. I guess you are also frustrated.

By the way I am not getting paid for this job, but that wouldn’t matter. It is Roots responsability to inform and teach the community about how to use and adopt its tool anyway.

I saw you deleted my other post. It doesn’t matter.

Sage is not relatively new.

It’s not our responsibility to teach you how to develop a website. For the third time, what you’ve described has nothing to do with Sage and have yet to prove otherwise.

You’ve spent a whole lot of time typing and apparently zero time debugging. You’ve spent 5 days to try and solve your problem?

I’ll be locking this thread if you continue to waste further time.

As a matter of course we often unlist topics that seem either unproductive or describe problems not related to the Roots stack. We frequently relist them if the problem proves to be Roots related, or of general interest to the community.

Sage isn’t new and we’re not aware of any problems, let alone several problems, that it has outside currently open issues on GitHub. If there are threads outlining these problems please link them here so that we can better understand what you’re talking about. We on the team and many community members do our best to address issues with Sage, Bedrock, and Trellis in this forum as our time and expertise allows.

We’re unaware of any situation or configuration which could create the problems you’re attributing to Sage. To continue troubleshooting this issue we will need to know what you’ve done to isolate the problem to Sage and what errors, specifically, you’re seeing. Not just the browser-side 404 errors, but also the underlying PHP errors on your server or development environment.

Nobody is mad, but so far you’ve provided no code, error messages or specifics about your environment or configuration, or troubleshooting steps you’ve tried on your own. Without this information we cannot help so we’ve unlisted this topic until you can provide it. Thanks!


Hey @pvargas,

As Ben and Michael mentioned, so far it doesn’t sound like an issue caused by Sage, and we would need additional information in order to understand why you think it is connected.

This is why we don’t think (so far) that it’s a Sage issue: that you’re getting a 404 error specifically and that the WordPress admin also isn’t working. That makes it sounds like a problem with your local dev setup, your WordPress installation, or your database.

You mentioned that your local setups normally work for you, but I don’t think you specifically said if this particular local WordPress install is functioning without Sage. If you haven’t already done so, please verify that the same WordPress installation works when you remove Sage and use something like Twenty Seventeen instead–no other changes, just swap them out. If the same exact setup works with Twenty Seventeen but not Sage, then that would sound more like it’s connected to the Sage theme.

Otherwise, more information would be helpful, as Michael said.

Yes, once you have your WordPress install working without Sage and are ready to try to add Sage again, you will need to enter the Sage directory on the command line and run:

composer install
yarn build

Under normal circumstances, if all three commands run successfully, Sage would be ready to be loaded. The final thing you might need to do to get everything working 100% is make sure the devUrl value in resources/assets/config.json accurately reflects your local setup, as the previous developer may have had things set up differently.

This topic was automatically closed after 42 days. New replies are no longer allowed.