Roots Discourse

Tried everything! Unable to open local-dev environment on any browser :(

Hi,

I am fairly new to this, and I can’t figure out why I am unable to open my local development environment on any browser in Windows 10. When I run ‘vagrant up’ I can see the VM in VirtualBox, and I can see that it is running.

I am using Vagrant 2.2.7, Ansible 2.9.6, VirtualBox 6.1.4

Can you explain what you mean by “unable to open”? What url are you visiting? What happens when you visit that URL? Can you ping the IP of your VM, and/or the domain name of your development site?

One of the first things you should probably check is that your hosts file contains the correct records to point request for your dev domain to your VM’s IP.

When I type ‘poorna.test’ (which I set in the wordpress_site file) into any browser the browser says it is unable to find the server IP address.

Can you explain what pinging the IP is? I am really new to the universe of web development.

ping 129.168.0.1

You just run the ping command from the cli with whatever the IP is that you want to test (the one above is just an example). ping just throws a few bytes at the IP and lets you know when it gets some back. It’s a good, simple way to know if your computer can see anything at a particular IP.

Sounds like it might be a hosts issue. Have you checked your hosts file? On Windows 10 it should be in c:\windows\system32\drivers\etc\hosts. You’ll need to open it w/ a text editor w/ elevated permissions or you won’t be able to make changes.

This explains a little bit about what the hosts file does: https://helpdeskgeek.com/windows-7/windows-7-hosts-file/ The short version is that it tells your computer what domain is associated with what IP.

Perhaps a dumb question, what do I check in the host file? I am able to open it.

Also, I can’t run vagrant ssh to get my ip address. Is there any other way to find out what it is?

This topic was automatically closed after 42 days. New replies are no longer allowed.