Trouble Connecting Sequel Pro to Vagrant

I have the Trellis > Bedrock > Sage stack going, and it seems to be working well. But it would be a huge help if I could get Sequel Pro to connect to my Vagrant database. I see others have done that without much trouble, but I’ve tried every combination I can come up with and it still won’t connect.

When it errors and I choose ‘show details’ it seems to be rejecting my private key, which should be what’s used when the Vagrant box gets built. Anyone have any suggestions?

You might have to do:

  StrictHostKeyChecking no

in your ~/.ssh/config

Connect via SSH of course

1 Like

Thanks Austin.

I added that, restarted the terminal, rebuilt the Vagrant box and still get the same error. Is the default MySQL Host or is it the VM private network IP?

If you haven’t tried it already, here is some sequel pro ssh connection info from a couple older threads:

Thanks guys! I finally got it working. I pulled down a fresh copy of the example project, set it up with defaults and was able to connect to the database. Not sure what got messed up there. I’ll just move everything over to this new stack and I should be good to go. Thanks for the help.