Use trellis on external drive

I have started to use trellis and bedrock to streamline my workflow developing wordpress apps for my clients. Unfortunately I’m not a pro dev and I progress quite slowly. The ‘framework’ is impressive and it works pretty well. I like it. I have started a couple projects on my laptop but I would really like having my development sites stored on an external disk.

Unfortunately, when I ‘power up’ vagrant I receive an error message, probably because of a SSH key problem. I have read of this kind of issues when installing on a non-system volume. Is there way to have it running on external drive?

Thank you

I just did this a few weeks ago to free up space on my MacBook. I followed a combination of both of these articles to get it done successfully:

1 Like

Hello there!

Thanks for your pointer. I tried following you advise but I stll get the same error:

The private key to connect to this box via SSH has invalid permissions

set on it. The permissions of the private key should be set to 0600, otherwise SSH will

ignore the key. Vagrant tried to do this automatically for you but failed. Please set the

permissions on the following file to 0600 and then try running this command again:

On the private key file current permissions are set to 777

I’m puzzled.

Can it be a file system issue? The disk is formatted as Ex Fat32

This is telling you exactly what the problem is: The permissions on the private key should be 0600, but they aren’t.

Windows does not have a permissions model like Linux, so you need to do some negotiating with WSL in order to get it to allow you to apply permissions the way Trellis wants you to. This post explains how to do that: Fix Windows Subsystem for Linux (WSL) File Permissions · Brian's Blog

Yep. That’s what I thought. The point is that I am using a mac. But the drive is formatted as ex fat32. out of the box. I suppose I should reformat the drive, at this point…

Sorry, I missed the part about your Mac. I’d assumed something formatted ExFAT would be on a Windows device.

Yeah, unless you’re going to be sharing it w/ non-Mac users I’d just reformat it to HFS or whatever the native Mac format is these days. AFAIK ExFAT isn’t going to support the kind of permissions you need. Sometimes you can get around that via symlinks and stuff, but IMO that’s more trouble than it’s worth. (Also I wouldn’t be surprised if your VMs take a performance hit because of MacOS’s negotiation w/ the ExFAT filesystem.)

Yep. I thought so. This disk needs to stay with this file system, so I bought a new disk which will be formatted accordingly. I’ll update the post asap. Thanks a lot for your advice.

Quick update: got a new disk and formatted in APFS, now everything works fine. Bringing up the VM is a little slow, but perfect under any other aspect. Now…my next question is: I am syncing a copy of the disk to Dropbox…just in case. I cannot copy several files which are actually aliases in ‘site/vendor/bin’ . Is it a big issue?

vendor is where Composer stores packages. The contents can easily be regenerated with composer install, so I wouldn’t worry about backing it up.

This topic was automatically closed after 42 days. New replies are no longer allowed.