Using Sage 9 On PHP 5.6.31

sage9

#1

I have a general question for why Sage 9 requires at least PHP version 5.6.4? It seems like 5.6.4 was mostly a bug fix release?

I guess what I’m asking is if it’s possible to use Sage 9 beta 3 on PHP v5.6.31?

I had previously tried activating after disabling the PHP version check and it caused a lot of errors.

I’m implementing this for a large multisite network at a university, so upgrading PHP could be a large task.


#2

I’m not sure what features Sage might be making use of in 5.6.4, but when released Sage 9 looks like it’ll require PHP7+, as per this merged pull request, so I’d recommend developing on that.


#3

Upgrading to PHP7 will take a while in my environment (lots of plugins with unknown php7 compatibility on a multisite with 1000s of users), but we need to launch this new theme sooner rather than later.

Hope there is some quick way to make Sage 9 compatible with 5.6.31 as a short term, quick solution.


#4

Sage 9 depends heavily on Blade templating, and the minimum required PHP version for that is 5.6.4 (source: https://github.com/illuminate/view/blob/5.4/composer.json). I’m not sure how you’d make it compatible with earlier versions without a lot of work.


#5

Understood. Short term solution will be to upgrade to 5.6.4 then, while we audit the plugins for PHP7 compatibility.

Thank you!


#6

No problem, hope you get it all figured out! Working with old systems can be a pain.