Vagrant Up export file invalid

Hi guys!

I’ve been trying to follow all the steps to setup a new project.

When starting the development server (vagrant up) I keep getting the following error message:

NFS is reporting that your exports file is invalid. Vagrant does
this check before making any changes to the file. Please correct
the issues below and execute "vagrant reload":

exports:5: path contains non-directory or non-existent components: /Users/Jan/Sites/vve_energie/site
exports:5: no usable directories in export entry
exports:5: using fallback (marked offline): /

I’m running vagrant version 1.7.2. and ansible 1.9.2.

As a result gulp-watch is stuck at “waiting for localhost”.

Any ideas?

1 Like

Does that folder actually exist?

It does not.

I’ve been trying the ‘let’s start over’ method. Could vagrant be trying to start up these old ones and fail?

I’ve tried to use “vagrant global-status” to destroy the unused. I can’t seem to delete the empty ones.

The working directory for Vagrant doesn't exist! This is the
specified working directory:

If you want to destroy a vagrant box, you can just open Virtualbox and see which VM’s are still active.

Trellis works very specifically with a Bedrock WordPress installation, that’s why it is pointed to a ../site directory. The minimum requirement is pointing it to a Bedrock installation so it can set up the VM correctly for you.

1 Like

Thanks for your reply, I think i’m getting somewhere. I have an older install i’ve been working with, which seems to work fine after I closed all the boxes down.

The new install gave me large output, which I believe was an install, without errors. It included tasks such as
TASK: [wordpress-install | Install WP]
TASK: [wordpress-install | Install Dependencies with Composer] etc.

When I run browsersync via gulp-watch, however, i still get a “waiting for localhost”. The page is not loading. I double checked the /assets/manifest.json as was mentioned in other posts.

Does the actual dev address work that you’ve set up in Trellis?

Thanks kalenjohnson, I’ve managed to fix the issue by using http://localhost:3002.

For future reference:

Problem: NFS is reporting that your exports file is invalid.

Solution: Close and remove all unused boxes. Check all credentials and /assets/manifest.json in sage and reinitialise.

1 Like

Thanks for sharing your solution, helped me out.

This did the trick for me…opened up the VBox GUI and stopped/removed my other failed attempts at Trellis VMs. Thanks!

I had this problem on Mac OSX after moving a project folder and NFS tried to mount to old location.

I tried looking for /var/exports file but it’s actually located in /etc/exports on Mac (atleast for me).

I modified it with the new project location and it solved the problem.


Thanks, this fixed it for me!

That did the trick for me, thanks :ok_hand: