Roots Discourse

Vagrant Up fails on new install

Today I tried to do vagrant-reload --provision on an install that I hadn’t provisioned in some time, and it threw an error at task [wordpress-install : Setup Permalink Structure]. It’s reporting a parse error Error: Error parsing . but I’m not sure what line it’s getting stuck on. I tried a vagrant destroy followed by a new vagrant up with the same result. Here’s the full error

TASK [wordpress-install : Setup Permalink Structure] ***************************
System info:
  Ansible 2.7.5; Vagrant 2.2.4; Darwin
  Trellis 1.0.3: April 30th, 2019
---------------------------------------------------
non-zero return code
Error: Error parsing .
failed: [default] (item=modernadventure.uno) => {"changed": true, "cmd": ["wp", "rewrite", "structure", "/%postname%/", "--allow-root"], "delta": "0:00:00.287351", "end": "2019-10-02 17:26:39.363531", "item": {"changed": true, "cmd": ["wp", "core", "install", "--allow-root", "--url=http://moad-uno.test", "--title=modernadventure.uno", "--admin_user=admin", "--admin_password=[redacted]", "--admin_email=[redacted]"], "delta": "0:00:02.867556", "end": "2019-10-02 17:26:38.867441", "failed": false, "invocation": {"module_args": {"_raw_params": "wp core install --allow-root --url=\"http://moad-uno.test\"  --title=\"modernadventure.uno\" --admin_user=\"admin\" --admin_password=\"[redacted]\" --admin_email=\"[redacted]\"", "_uses_shell": false, "argv": null, "chdir": "/srv/www/modernadventure.uno/current/", "creates": null, "executable": null, "removes": null, "stdin": null, "warn": true}}, "item": {"key": "modernadventure.uno", "value": {"admin_email": "[redacted]", "cache": {"enabled": false}, "local_path": "../site", "multisite": {"enabled": false}, "site_hosts": [{"canonical": "moad-uno.test"}], "ssl": {"enabled": false, "hsts_max_age": 0, "provider": "self-signed"}}}, "rc": 0, "start": "2019-10-02 17:26:35.999885", "stderr": "sh: 1: /usr/sbin/sendmail: not found", "stderr_lines": ["sh: 1: /usr/sbin/sendmail: not found"], "stdout": "Success: WordPress installed successfully.", "stdout_lines": ["Success: WordPress installed successfully."]}, "rc": 1, "start": "2019-10-02 17:26:39.076180", "stderr_lines": ["Error: Error parsing ."], "stdout": "", "stdout_lines": []}

Any ideas?

Turns out I had a misconfigured third-party library, WP Plugin Activation Manifest. vagrant reload --provision is completing successfully again after I fixed the installation and routing for this library.