Roots Discourse

"Vagrant Up" is showing an error suddenly when it has never before

Vagrant failed to initialize at a very early stage:

Vagrant failed to properly resolve required dependencies. These
errors can commonly be caused by misconfigured plugin installations
or transient network issues. The reported error is:

vagrant-bindfs requires Ruby version ~> 2.2, < 2.7. The current ruby version is 2.7.0.0.

I didn’t upgrade ruby on the VM or anything, but now I can’t get it started. Ruby on my PC has been 2.7.0 for a while but this issue is new today.

Edit: How do I install a local copy of vagrant-bindfs? I know the latest version works with Ruby 2.7, even though it’s not official. I removed the restriction in the file but I’m not sure how to install it.

1 Like

vagrant bundles its own ruby.
Did you upgrade vagrant recently?

I had this issue on Arch, to solve it I downgraded to the following packages:

  • vagrant 2.2.6-2
  • ruby 2.6.5-1
  • rubygems 3.0.6-1
    `