Roots Discourse

Weird Cannot read property 'substring' error in grunt-contrib-less

Hi there, I started doing some updates on an older project with the Roots 6.5.2 version and Grunt.
My javascript compiles fine, but when I change something in my assets/less/app.less file I suddenly get this weird error while running gulp watch:

Running "watch" task
Waiting...OK
>> File "assets/less/app.less" changed.

Running "less:dev" (less) task
>> SyntaxError: Cannot read property 'substring' of undefined in assets/less/app.less on line null, column 0:
>> 1 @import "bootstrap/bootstrap.less";
Warning: Error compiling assets/less/app.less Use --force to continue.

First line is just the default bootstrap import:
@import "bootstrap/bootstrap.less";

Tried removing node_modules folder and re-install with npm install, but still same error…
Any idea what might be causing this?

Thanks

Hmm, still not sure what’s causing this, but setting sourceMap to false in my Gruntfile did the trick.

hmm, not sure. Will be can’t find the location file of the CSS.