Roots Discourse

Why does `vagrant up` require use of microphone?


#1

I recently came back to using Roots.io after a while and wanted to set up a new WordPress website. As I walked through the steps of setting up Trellis and Bedrock, my iTerm came up with a pop-up asking permission to use my microphone. I declined because I can’t think of a single reason why setting up a WP website would require that. Things broke, and I tried it again after giving permission to use the microphone and everything ran smoothly.

TL;DR: vagrant up requires use of my microphone to work. What’s the deal?


#2

I have no idea why it would ask that. It’s certainly nothing in Trellis itself and I don’t know why Vagrant would cause that either. Could be an iTerm bug?


#3

I am on MacOS Mojave and I know with that update permissions got locked down a lot more and requires apps to double check with everything. It seems like one of the scripts being run (whether it’s Roots, Vagrant or something else) is requiring use of the Microphone. When iTerm is running scripts, it requests permissions based on what the script needs. So for example, if I ran a script that took a picture with my laptop’s camera, iTerm would request use of the camera.


#4

Well if you find out what’s causing this, please let us know :slight_smile:

I can’t think of anything we’d use which would even ask for the microphone (and certainly doesn’t actually use it).


#5

This is a bug with iTerm 3.2.3 (maybe other versions). It’s not directly related to the roots stack. Upgrading to iTerm 3.2.5 solves the issue, unfortunately I can’t find the issue which referenced this but I believe it was on the iTerm official repo


#6

Interesting, thanks for this Craig. That being said, a day later on my machine, I got a pop up after restarting my computer, this time the system prompting me saying Virtual Box wanted access to my microphone. Very strange. But as suggested by everyone, doesn’t seem to be a Roots issue, just an issue from the technologies it uses, and in one case, the technologies I’m using.


#7

Just disable audio directly on Virtualbox: VM Settings > audio > Uncheck “Enable Audio”.

It appears that its being enabled by default.