[WIN 10] Install hangs at task Wordpress install: Install dependencies with Composer

This is a really annoying problem, and I have tried a few things to solve it. Everything from deleting it all and downloading it all fresh off Github, to following instructions on various threads here on the forum.
But no luck.

Upon running Vagrant up, the process goes through up until TASK [wordpress-install: Install Dependencies with Composer], then completely hangs. I’ve tried it on two different machines, and the same thing happens. I left it running for about 1 hour, thinking it might be a large download or something similar, but no. Running vagrant reload -- provision returns the same problem.

There is no output, so I don’t know where to look. My last hope is that someone here is able to help out and try to figure out what causes it and how to fix it. :slight_smile:

My environment specs are as follows,
Windows 10 Pro 64-bit
vagrant version: 2.2.1
Virtualbox version: 5.2.18 r124319 (Qt5.6.2)

Don’t know if it is worth mentioning, but when logging into the Trellis box over SSH after aborting the progress…I navigate to the /srv/www/demo-folder where my project is supposed to be, and run a simple ls command, the entire thing hangs and does not list contents. I then have to force quit from PowerShell.

Have you tried passing -v to the Composer arguments in Trellis’s configuation to see if you can get more information out of Composer at this stage? This should be the line to modify: https://github.com/roots/trellis/blob/4c69ace545647e8a5d3612811865e349a0b51725/roles/wordpress-install/tasks/main.yml#L31

I just tried that now, and it did nothing. Same result as before. ARe you sure it is line 31? Because it seems to reference packagist.com and not the “Install Dependencies with Composer”.

Even vanilla config of Trellis seems to hang at that same task, even if changing to another ubuntu box in the vagrant file.

Just wanted to say I’m also experiencing this exact issue but I’m running Ubuntu 16.04 as my host. I’m also using a vanilla config of Trellis.

Ubuntu 16.04, vagrant 2.2.1, virtualbox 5.2.22 r126460 (Qt5.6.1)

I believe the issue happens when Composer is using the unarchiver on squizlabs/php_codesniffer package. Something about that package causes the unarchiver to hang, thus, Composer hangs. I could recreate the hanging just by wget-ing the latest squizlabs/php_codesniffer release and trying to unzip it on the VM.

I’ve tried forcing Composer to download package 3.0.2 but it still fails; however, after removing the package from the VM’s /srv/www/[project]/current/composer.json, I could complete the provisioning.

At first I couldn’t access my VM’s /srv/www/[project]/current/* directory because it was locked by the Composer process, so here’s what I did to fix my issue:

  1. Manually shut down the VM via VirtualBox
  2. Start up the VM from your local trellis directory: vagrant up
  3. Log into the VM: vagrant ssh
  4. cd /srv/www/[project]/current/
  5. Modify your composer.json file, remove the squizlabs/php_codesniffer dependency.
  6. composer clear-cache
  7. composer update
  8. exit
  9. From your local trellis directory: vagrant provision

Ok, so I tried that and still got the same result.
While running composer update I got the following message before process completely halts to a grinding stop again.

I edited the /srv/www/demo/current/composer.json from within the VM, and as I have the plugin vagrant-winnfsd I could see changes to the file live in my Visual Code IDE.

List of plugins in my Vagrant (not sure if it relevant at all),

  • landrush (1.3.0, global)
  • vagrant-alpine (0.3.0, global)
  • vagrant-bindfs (1.1.0, global)
  • vagrant-fsnotify (0.3.0, global)
  • vagrant-host-shell (0.0.4, global)
  • vagrant-hostmanager (1.8.9, global)
  • vagrant-hostsupdater (, global)
  • vagrant-vbguest (0.16.0, global)
  • vagrant-winnfsd (1.4.0, global)

As there is no 'unzip' command installed zip files are being unpacked using the PHP zip extension. This may cause invalid reports of corrupted archives. Besides, any UNIX permissions (e.g. executable) defined in the archives will be lost. Installing 'unzip' may remediate them. - Installing roots/wp-config (1.0.0): Downloading (100%) <-- this is where the process stops…

How do I determine what dependency is not working, and where are these dependencies listed?
I am thinking something is seriously wrong with either my environment or this particular Trellis-Bedrock setup. I can’t afford to spend hours on end trying to fix things, no matter how great this thing is or how great this community is. Don’t get me wrong, I really like this Roots.io packaged developer box…but if it is not working I have to look somewhere else or just configure my own.

I really do appreciate all help on getting this thing to run, so that I can develop sites and “onboard” more people on the Trellis-Bedrock combination. :slight_smile:

Thank you in advance for all assistance.

Because it stops after the “…(100%)”, I’m assuming it’s still the unarchiver failing.

After step #4, do the following:

4b. sudo apt install unzip
4c. Remove all folders/files in the /srv/www/demo/current/vendor/ directory.

If it hangs again show us a listing of the vendor directory.

(Full disclosure: yesterday was my first day trying out Trellis and Bedrock, so I’m out of my depth and also disappointed that I ran into issues trying to set up a demo project.)

Try downgrading Vagrant to 2.1.1 (and vagrant-hostmanager to 1.8.7). It does work for me OK on a Windows 10 Pro 64-bit host w/ VMware Workstation Pro.

Ok, so I tried experimenting with this quite a bit. I deleted everything in the vendor folder and then watched it as the composer script ran. It runs smoothly until it hits a “brick wall” on the dependency install task. It seems to be something with the roots folder that stops it all.

I then edited out wp-password-encrypt from composer.json, just to see what result I would get. Same result, a brick wall. I then removed wp-config from composer.json. But that seemed to break it all since it requires information from it.

I now got this message,

System info:
  Ansible 2.5.3; Vagrant 2.2.1; Linux
  Trellis version (per changelog): Allow customizing Nginx worker_connections

non-zero return code
PHP Fatal error:  Uncaught Error: Class 'Roots\WPConfig\Config' not found in
Stack trace:
#0 phar:///usr/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1150) :
eval()'d code(7): require_once()
#1 phar:///usr/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1150):
#2 phar:///usr/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1111):
#3 phar:///usr/bin/wp/vendor/wp-cli/wp-
cli/php/WP_CLI/Bootstrap/LaunchRunner.php(23): WP_CLI\Runner->start()
#4 phar:///usr/bin/wp/vendor/wp-cli/wp-cli/php/bootstrap.php(74): WP_CLI\Boot
#5 phar:///usr/bin/wp/vendor/wp-cli/wp-cli/php/wp-cli.php(23):
#6 phar:///usr/bin/wp/php/boot-phar.php(11): include('phar:///usr/bin...')
#7 /usr/bin/wp(4): include('phar:///usr/bin...')
#8 {main}
  thrown in /srv/www/demo/current/config/application.php on line 42
failed: [default] (item=demo) => {"changed": true, "cmd": ["wp", "core", "install", "--allow-root", "--url=http://demo.tld", "--title=demo", "--admin_user=admin", "--admin_password=admin", "--admin_email=admin@demo.tld"], "delta": "0:00:00.195271", "end": "2018-11-25 16:13:59.429047", "item": "demo", "rc": 255, "start": "2018-11-25 16:13:59.233776", "stderr_lines": ["PHP Fatal error:  Uncaught Error: Class 'Roots\\WPConfig\\Config' not found in /srv/www/demo/current/config/application.php:42", "Stack trace:", "#0 phar:///usr/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1150) : eval()'d code(7): require_once()", "#1 phar:///usr/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1150): eval()", "#2 phar:///usr/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1111): WP_CLI\\Runner->load_wordpress()", "#3 phar:///usr/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Bootstrap/LaunchRunner.php(23): WP_CLI\\Runner->start()", "#4 phar:///usr/bin/wp/vendor/wp-cli/wp-cli/php/bootstrap.php(74): WP_CLI\\Bootstrap\\LaunchRunner->process(Object(WP_CLI\\Bootstrap\\BootstrapState))", "#5 phar:///usr/bin/wp/vendor/wp-cli/wp-cli/php/wp-cli.php(23): WP_CLI\\bootstrap()", "#6 phar:///usr/bin/wp/php/boot-phar.php(11): include('phar:///usr/bin...')", "#7 /usr/bin/wp(4): include('phar:///usr/bin...')", "#8 {main}", "  thrown in /srv/www/demo/current/config/application.php on line 42"], "stdout": "", "stdout_lines": []}

Sorry for the big chunk of code. But as it seems now, there is something with roots/wp-config": "1.0.0"that causes it to hit that brick wall. So I put the WP-config back into composer.json.
The folder vendor/roots/wp-config then contains 1 file called 2c21dccab8bb895ab4d26e9b4287b670.
The file is not readable, and is “garbled”

My vendor folder has 4 folders after this procedure.

  • composer
  • johnpbloch
  • oscarotero
  • roots ← this folder have wp-config and wp-password-bcrypt

I am suspecting this issue has something to do with wp-config task failing somehow. We need some help! :slight_smile:

I don’t think roots/wp-config is the problem, but you can confirm by installing an older version of Bedrock instead. Make a backup of your original site (if it had any changes) and install Bedrock 1.8.12:

# @ /path/to/your/roots/project/
$ composer create-project roots/bedrock:1.8.12 site


# @ /path/to/your/roots/project/
$ git clone --branch=1.8.12 --depth=1 https://github.com/roots/bedrock.git site 

roots/wp-config was introduced in Bedrock 1.9.0 and is used for defining environment variables, so it would break your install if removed.

Thanks for helping out. :slight_smile:
However, even when using 1.8.12 it hits a “brick wall” at the installation of dependencies.
This time I only have composer and johnpbloch folders in vendor.

I’m thinking that it might be Trellis-related, rather than Bedrock…but I don’t know where to look.
I ran this install clean, I destroyed the previous box and made a new one. Still same result.

Here’s the output:
PS D:\websites\goodfriends.website\trellis> vagrant up
Bringing machine ‘default’ up with ‘virtualbox’ provider…
==> default: Importing base box ‘bento/ubuntu-16.04’…
==> default: Matching MAC address for NAT networking…
==> default: Checking if box ‘bento/ubuntu-16.04’ is up to date…
==> default: Setting the name of the VM: demo.tld
==> default: Clearing any previously set network interfaces…
==> default: Preparing network interfaces based on configuration…
default: Adapter 1: nat
default: Adapter 2: hostonly
==> default: Forwarding ports…
default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Running ‘pre-boot’ VM customizations…
==> default: Booting VM…
==> default: Waiting for machine to boot. This may take a few minutes…
default: SSH address:
default: SSH username: vagrant
default: SSH auth method: private key
default: Vagrant insecure key detected. Vagrant will automatically replace
default: this with a newly generated keypair for better security.
default: Inserting generated public key within guest…
default: Removing insecure key from the guest if it’s present…
default: Key inserted! Disconnecting and reconnecting using new SSH key…
==> default: Machine booted and ready!
[default] GuestAdditions versions on your host (5.2.22) and guest (5.2.18) do not match.
Reading package lists…
Building dependency tree…
Reading state information…
dkms is already the newest version (
The following NEW packages will be installed:
linux-headers-4.4.0-116 linux-headers-4.4.0-116-generic
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 10.7 MB of archives.
After this operation, 78.2 MB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-headers-4.4.0-116 all 4.4.0-116.140 [9,922 kB]
Get:2 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 linux-headers-4.4.0-116-generic amd64 4.4.0-116.140 [774 kB]
dpkg-preconfigure: unable to re-open stdin: No such file or directory
Fetched 10.7 MB in 12s (840 kB/s)
Selecting previously unselected package linux-headers-4.4.0-116.
(Reading database … 38378 files and directories currently installed.)
Preparing to unpack …/linux-headers-4.4.0-116_4.4.0-116.140_all.deb …
Unpacking linux-headers-4.4.0-116 (4.4.0-116.140) …
Selecting previously unselected package linux-headers-4.4.0-116-generic.
Preparing to unpack …/linux-headers-4.4.0-116-generic_4.4.0-116.140_amd64.deb …
Unpacking linux-headers-4.4.0-116-generic (4.4.0-116.140) …
Setting up linux-headers-4.4.0-116 (4.4.0-116.140) …
Setting up linux-headers-4.4.0-116-generic (4.4.0-116.140) …
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 4.4.0-116-generic /boot/vmlinuz-4.4.0-116-generic
Copy iso file C:\Program Files\Oracle\VirtualBox\VBoxGuestAdditions.iso into the box /tmp/VBoxGuestAdditions.iso
Mounting Virtualbox Guest Additions ISO to: /mnt
mount: /dev/loop0 is write-protected, mounting read-only
Installing Virtualbox Guest Additions 5.2.22 - guest version is 5.2.18
Verifying archive integrity… All good.
Uncompressing VirtualBox 5.2.22 Guest Additions for Linux…
VirtualBox Guest Additions installer
Removing installed version 5.2.18 of VirtualBox Guest Additions…
Copying additional installer modules …
Installing additional modules …
VirtualBox Guest Additions: Building the VirtualBox Guest Additions kernel modules. This may take a while.
update-initramfs: Generating /boot/initrd.img-4.4.0-116-generic
VirtualBox Guest Additions: Running kernel modules will not be replaced until the system is restarted
VirtualBox Guest Additions: Starting.
An error occurred during installation of VirtualBox Guest Additions 5.2.22. Some functionality may not work as intended.
In most cases it is OK that the “Window System drivers” installation failed.
Unmounting Virtualbox Guest Additions ISO from: /mnt
Got different reports about installed GuestAdditions version:
Virtualbox on your host claims: 5.2.18
VBoxService inside the vm claims: 5.2.22
Going on, assuming VBoxService is correct…
Got different reports about installed GuestAdditions version:
Virtualbox on your host claims: 5.2.18
VBoxService inside the vm claims: 5.2.22
Going on, assuming VBoxService is correct…
==> default: Checking for guest additions in VM…
==> default: [vagrant-hostsupdater] Checking for host entries
==> default: [vagrant-hostsupdater] Skipping adding host entries (config.vm.network hostsupdater: “skip” is set)
==> default: Setting hostname…
==> default: Configuring and enabling network interfaces…
==> default: Automatic installation for Landrush IP not enabled
==> default: Exporting NFS shared folders…
==> default: Preparing to edit nfs mounting file.
[NFS] Status: halted
[NFS] Start: started
==> default: Mounting NFS shared folders…
==> default: Mounting shared folders…
default: /vagrant => D:/websites/goodfriends.website/trellis
==> default: Checking for bindfs in VM…
default: Package manager detected: apt-get
default: Fuse kernel module is installed
default: Fuse kernel module is loaded
==> default: Bindfs seems to not be installed on the virtual machine, installing now
default: Bindfs 1.12.6 is installed
==> default: Machine is ready to use bindfs!
==> default: Creating bind mounts after synced_folders…
default: /vagrant-nfs-demo => /srv/www/demo/current
default: /ansible-nfs => /home/vagrant/trellis
default: /home/vagrant/trellis/bin => /home/vagrant/trellis/bin
==> default: [vagrant-hostmanager:guests] Updating hosts file on active guest virtual machines…
==> default: [vagrant-hostmanager:host] Updating hosts file on your workstation (password may be required)…
==> default: Running provisioner: ansible_local…
default: Installing Ansible…
default: Installing pip… (for Ansible installation)
default: Running ansible-galaxy…

PLAY [WordPress Server: Install LEMP Stack with PHP 7.2 and MariaDB MySQL] *****

TASK [Gathering Facts] *********************************************************
ok: [default]

TASK [common : Load wordpress_sites.yml vars into _sites vars] ************
skipping: [default] => (item=development)

TASK [common : Fail if there are duplicate site keys within host’s wordpress_sites] ***

TASK [common : Validate wordpress_sites] ***************************************
skipping: [default]

TASK [common : Validate format of site_hosts] **********************************
skipping: [default] => (item=demo)

TASK [common : Verify dict format for apt package component variables] *********
skipping: [default]

TASK [common : Verify dict format for apt package combined variables] **********
skipping: [default]

TASK [common : Validate Ubuntu version] ****************************************
skipping: [default]

TASK [common : Check whether passlib is needed] ********************************
skipping: [default]

TASK [common : Retrieve local SSH client’s settings per host] ******************
ok: [default]

TASK [common : Validate compatible settings between SSH client and server] *****
ok: [default] => {
“changed”: false,
“msg”: “All assertions passed”

TASK [common : Checking essentials] ********************************************
changed: [default] => (item=python-software-properties)
ok: [default] => (item=build-essential)
ok: [default] => (item=git)
changed: [default] => (item=python-mysqldb)
changed: [default] => (item=libnss-myhostname)
ok: [default] => (item=dbus)
ok: [default] => (item=python-pycurl)
ok: [default] => (item=curl)

TASK [common : Validate timezone variable] *************************************
ok: [default]

TASK [common : Explain timezone error] *****************************************
skipping: [default]

TASK [common : Add myhostname to nsswitch.conf to ensure resolvable hostname] ***
ok: [default]

TASK [common : Generate SSH key for vagrant user] ******************************
changed: [default]

TASK [common : Retrieve SSH client IP] *****************************************
skipping: [default]

TASK [fail2ban : ensure fail2ban is installed] *********************************
changed: [default]

TASK [fail2ban : ensure fail2ban is configured] ********************************
changed: [default] => (item=jail.local)
changed: [default] => (item=fail2ban.local)

TASK [fail2ban : ensure fail2ban starts on a fresh reboot] *********************
ok: [default]

TASK [ferm : ensure ferm status is in debconf] *********************************
changed: [default]

TASK [ferm : ensure ferm is installed] *****************************************
changed: [default]

TASK [ferm : ensure configuration directories exist] ***************************
changed: [default] => (item=/etc/ferm/ferm.d)
changed: [default] => (item=/etc/ferm/filter-input.d)

TASK [ferm : ensure firewall is configured] ************************************
changed: [default] => (item=etc/default/ferm)
changed: [default] => (item=etc/ferm/ferm.conf)

TASK [ferm : ensure iptables INPUT rules are removed] **************************
skipping: [default] => (item={u’dport’: [u’http’, u’https’], u’type’: u’dport_accept’, u’filename’: u’nginx_accept’})
skipping: [default] => (item={u’dport’: [u’ssh’], u’type’: u’dport_accept’, u’saddr’: [u’’]})
skipping: [default] => (item={u’dport’: [u’ssh’], u’seconds’: 300, u’hits’: 20, u’type’: u’dport_limit’})

TASK [ferm : ensure iptables INPUT rules are added] ****************************
changed: [default] => (item={u’dport’: [u’http’, u’https’], u’type’: u’dport_accept’, u’filename’: u’nginx_accept’})
changed: [default] => (item={u’dport’: [u’ssh’], u’type’: u’dport_accept’, u’saddr’: [u’’]})
changed: [default] => (item={u’dport’: [u’ssh’], u’seconds’: 300, u’hits’: 20, u’type’: u’dport_limit’})

TASK [ferm : ensure iptables rules are enabled] ********************************
skipping: [default]

TASK [ferm : ensure iptables rules are disabled] *******************************
ok: [default]

TASK [ntp : Include OS-specific variables.] ************************************
ok: [default]

TASK [ntp : Ensure NTP-related packages are installed.] ************************
changed: [default]

TASK [ntp : Ensure tzdata package is installed (Linux).] ***********************
ok: [default]

TASK [ntp : include_tasks] *****************************************************
skipping: [default]

TASK [ntp : Set timezone] ******************************************************
changed: [default]

TASK [ntp : Ensure NTP is running and enabled as configured.] ******************
ok: [default]

TASK [ntp : Ensure NTP is stopped and disabled as configured.] *****************
skipping: [default]

TASK [ntp : Generate ntp.conf file] ********************************************
changed: [default]

TASK [sshd : Ensure latest SSH server and client are installed] ****************
changed: [default] => (item=openssh-server)
ok: [default] => (item=openssh-client)

TASK [sshd : Create a secure sshd_config] **************************************
changed: [default]

TASK [sshd : Create a secure ssh_config] ***************************************
changed: [default]

TASK [sshd : Remove Diffie-Hellman moduli of size < 2000] **********************
changed: [default]

TASK [mariadb : Add MariaDB APT key] *******************************************
changed: [default]

TASK [mariadb : Add MariaDB PPA] ***********************************************
changed: [default]

TASK [mariadb : Install MySQL client] ******************************************
changed: [default]

TASK [mariadb : Install MySQL server] ******************************************
changed: [default]

TASK [mariadb : Disable MariaDB binary logging] ********************************
changed: [default]

TASK [mariadb : Set root user password] ****************************************
changed: [default] => (item=default)
changed: [default] => (item=
changed: [default] => (item=::1)
changed: [default] => (item=localhost)

TASK [mariadb : Copy .my.cnf file with root password credentials.] *************
changed: [default]

TASK [mariadb : Delete anonymous MySQL server users] ***************************
ok: [default] => (item=localhost)
ok: [default] => (item=default)
ok: [default] => (item=demo)

TASK [mariadb : Remove the test database] **************************************
ok: [default]

TASK [geerlingguy.daemonize : Download daemonize archive.] *********************
changed: [default]

TASK [geerlingguy.daemonize : Expand daemonize archive.] ***********************
changed: [default]

TASK [geerlingguy.daemonize : Check if daemonize is installed.] ****************
ok: [default]

TASK [geerlingguy.daemonize : Build daemonize.] ********************************
changed: [default] => (item=./configure --prefix=/usr)
changed: [default] => (item=make)
changed: [default] => (item=make install)

TASK [mailhog : Ensure mailhog install directory exists.] **********************
changed: [default]

TASK [mailhog : Download MailHog and mhsendmail binaries.] *********************
changed: [default] => (item={u’url’: u’https://github.com/mailhog/MailHog/releases/download/v0.2.1/MailHog_linux_amd64’, u’dest’: u’/opt/mailhog/mailhog’})
changed: [default] => (item={u’url’: u’https://github.com/mailhog/mhsendmail/releases/download/v0.2.0/mhsendmail_linux_amd64’, u’dest’: u’/opt/mailhog/mhsendmail’})

TASK [mailhog : Copy mailhog init script into place.] **************************
skipping: [default]

TASK [mailhog : Copy mailhog systemd unit file into place (for systemd systems).] ***
changed: [default]

TASK [mailhog : Ensure mailhog is enabled and will start on boot.] *************
changed: [default]

TASK [php : Add PHP 7.2 PPA] ***************************************************
changed: [default]

TASK [php : Install PHP 7.2] ***************************************************
changed: [default] => (item=php7.2-fpm)
ok: [default] => (item=php7.2-cli)
changed: [default] => (item=php7.2-mysql)
changed: [default] => (item=php7.2-xml)
changed: [default] => (item=php7.2-curl)
changed: [default] => (item=php7.2-dev)
changed: [default] => (item=php7.2-xmlrpc)
ok: [default] => (item=php7.2-opcache)
changed: [default] => (item=php7.2-gd)
ok: [default] => (item=php7.2-common)
changed: [default] => (item=php7.2-mbstring)
changed: [default] => (item=php7.2-zip)

TASK [php : Start php7.2-fpm service] ******************************************
ok: [default]

TASK [php : Check for existing php7.1-fpm service] *****************************
ok: [default]

TASK [php : Stop php7.1-fpm service if it exists] ******************************
skipping: [default]

TASK [php : PHP configuration file] ********************************************
changed: [default]

TASK [xdebug : Install Xdebug] *************************************************
changed: [default]

TASK [xdebug : Template the Xdebug configuration file] *************************
changed: [default]

TASK [xdebug : Ensure 20-xdebug.ini is present] ********************************
ok: [default]

TASK [xdebug : Disable Xdebug] *************************************************
skipping: [default]

TASK [xdebug : Disable Xdebug CLI] *********************************************
changed: [default]

TASK [memcached : Install memcached] *******************************************
changed: [default] => (item=memcached)
changed: [default] => (item=php-memcached)

TASK [memcached : Copy the client configuration file] **************************
changed: [default]

TASK [memcached : Set the max open file descriptors] ***************************
changed: [default]

TASK [memcached : Start the memcached service] *********************************
ok: [default]

TASK [nginx : Add Nginx PPA] ***************************************************
changed: [default]

TASK [nginx : Install Nginx] ***************************************************
changed: [default]

TASK [nginx : Create SSL directory] ********************************************
changed: [default]

TASK [nginx : Generate strong unique Diffie-Hellman group.] ********************
skipping: [default]

TASK [nginx : Copy h5bp configs] ***********************************************
changed: [default]

TASK [nginx : Create nginx.conf] ***********************************************
changed: [default]

TASK [nginx : Disable default server] ******************************************
changed: [default]

TASK [nginx : Enable Nginx to start on boot] ***********************************
changed: [default]

TASK [logrotate : nickhammond.logrotate | Install logrotate] *******************
ok: [default]

TASK [logrotate : nickhammond.logrotate | Setup logrotate.d scripts] ***********
changed: [default] => (item={u’path’: u’/srv/www/**/logs/*.log’, u’options’: [u’weekly’, u’maxsize 50M’, u’missingok’, u’rotate 8’, u’compress’, u’delaycompress’, u’notifempty’, u’create 0640 vagrant www-data’, u’sharedscripts’], u’name’: u’wordpress-sites’, u’scripts’: {u’postrotate’: u’service nginx rotate’, u’prerotate’: u’if [ -d /etc/logrotate.d/httpd-prerotate ]; then \\n run-parts /etc/logrotate.d/httpd-prerotate; \\n fi \\n’}})

TASK [composer : Set php_executable variable to a default if not defined.] *****
ok: [default]

TASK [composer : Check if Composer is installed.] ******************************
ok: [default]

TASK [composer : Download Composer installer.] *********************************
changed: [default]

TASK [composer : Run Composer installer.] **************************************
changed: [default]

TASK [composer : Move Composer into globally-accessible location.] *************
changed: [default]

TASK [composer : Update Composer to latest version (if configured).] ***********
ok: [default]

TASK [composer : Ensure composer directory exists.] ****************************
ok: [default]

TASK [composer : Add GitHub OAuth token for Composer (if configured).] *********
skipping: [default]

TASK [composer : include_tasks] ************************************************
included: /home/vagrant/trellis/vendor/roles/composer/tasks/global-require.yml for default

TASK [composer : Install configured globally-required packages.] ***************
changed: [default] => (item={u’name’: u’hirak/prestissimo’})

TASK [composer : Add composer_home_path bin directory to global $PATH.] ********
changed: [default]

TASK [composer : include_tasks] ************************************************
skipping: [default]

TASK [wp-cli : Ensure gpg2 is installed] ***************************************
changed: [default]

TASK [wp-cli : Download WP-CLI Phar] *******************************************
changed: [default]

TASK [wp-cli : Download WP-CLI Phar Signature] *********************************
changed: [default]

TASK [wp-cli : Copy WP-CLI release team public key] ****************************
changed: [default]

TASK [wp-cli : Verify WP-CLI Phar Signature] ***********************************
ok: [default]

TASK [wp-cli : Install WP-CLI] *************************************************
changed: [default]

TASK [wp-cli : Retrieve WP-CLI tab completions] ********************************
changed: [default]

TASK [wp-cli : Install WP-CLI tab completions] *********************************
changed: [default]

TASK [wp-cli : Install WP-CLI packages] ****************************************

TASK [wordpress-setup : Create databases for sites] ****************************
changed: [default] => (item=demo)

TASK [wordpress-setup : Create/assign database user to db and grant permissions] ***
changed: [default] => (item=demo)

TASK [wordpress-setup : Generate self-signed certificates] *********************
skipping: [default] => (item=demo)
skipping: [default] => (item=no_default)

TASK [wordpress-setup : Download client cert] **********************************
skipping: [default] => (item=demo)

TASK [wordpress-setup : Create web root] ***************************************
changed: [default]

TASK [wordpress-setup : Create logs folder of sites] ***************************
changed: [default] => (item=demo)

TASK [wordpress-setup : Create WordPress php-fpm configuration file] ***********
changed: [default]

TASK [wordpress-setup : Disable default PHP-FPM pool] **************************
changed: [default]

TASK [wordpress-setup : Build list of Nginx includes templates] ****************
ok: [default]

TASK [wordpress-setup : Warn about deprecated Nginx includes directory] ********
skipping: [default]

TASK [wordpress-setup : Create includes.d directories] *************************

TASK [wordpress-setup : Template files out to includes.d] **********************

TASK [wordpress-setup : Retrieve list of existing files in includes.d] *********
ok: [default]

TASK [wordpress-setup : Remove unmanaged files from includes.d] ****************

TASK [wordpress-setup : Copy SSL cert] *****************************************
skipping: [default] => (item=demo)

TASK [wordpress-setup : Copy SSL key] ******************************************
skipping: [default] => (item=demo)

TASK [wordpress-setup : disable temporary challenge sites] *********************
ok: [default] => (item=demo)

TASK [wordpress-setup : Create Nginx available sites] **************************
changed: [default] => (item={u’src’: u’no-default.conf.j2’})
skipping: [default] => (item={u’src’: u’ssl.no-default.conf.j2’, u’enabled’: False})

TASK [wordpress-setup : Enable or disable Nginx sites] *************************
changed: [default] => (item={u’src’: u’no-default.conf.j2’})
ok: [default] => (item={u’src’: u’ssl.no-default.conf.j2’, u’enabled’: False})

TASK [wordpress-setup : Create Nginx conf for challenges location] *************
changed: [default]

TASK [wordpress-setup : Create WordPress configuration for Nginx] **************
changed: [default] => (item=demo)

TASK [wordpress-setup : Enable WordPress site] *********************************
changed: [default] => (item=demo)

TASK [wordpress-setup : Setup WP system cron] **********************************
changed: [default] => (item=demo)

TASK [wordpress-setup : Setup WP Multisite system cron] ************************
ok: [default] => (item=demo)

TASK [wordpress-install : Create web root of sites] ****************************
ok: [default] => (item=demo)

TASK [wordpress-install : Create shared folder of sites] ***********************
changed: [default] => (item=demo)

TASK [wordpress-install : Change site owner to user] ***************************
changed: [default] => (item=demo)

TASK [wordpress-install : Create .env file] ************************************
changed: [default] => (item=demo)

TASK [wordpress-install : Copy .env file into web root] ************************
changed: [default] => (item=demo)

TASK [wordpress-install : Add known_hosts] *************************************
changed: [default] => (item=github.com ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAQEAq2A7hRGmdnm9tUDbO9IDSwBK6TbQa+PXYPCPy6rbTrTtw7PHkccKrpp0yVhp5HdEIcKr6pLlVDBfOLX9QUsyCOV0wzfjIJNlGEYsdlLJizHhbn2mUjvSAHQqZETYP81eFzLQNnPHt4EVVUh7VfDESU84KezmD5QlWpXLmvU31/yMf+Se8xhHTvKSCZIFImWwoG6mbUoWf9nzpIoaSjB+weqqUUmpaaasXVal72J+UX2B+2RPW3RcT0eOzQgqlJL3RKrTJvdsjE3JEAvGq3lGHSZXy28G3skua2SmVi/w4yCE6gbODqnTWlg7+wC604ydGXA8VJiS5ap43JXiUFFAaQ==)
changed: [default] => (item=bitbucket.org ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAQEAubiN81eDcafrgMeLzaFPsw2kNvEcqTKl/VqLat/MaB33pZy0y3rJZtnqwR2qOOvbwKZYKiEO1O6VqNEBxKvJJelCq0dTXWT5pbO2gDXC6h6QDXCaHo6pOHGPUy+YBaGQRGuSusMEASYiWunYN0vCAI8QaXnWMXNMdFP3jHAJH0eDsoiGnLPBlBp4TNm6rYI74nMzgz3B9IikW4WVK+dc8KZJZWYjAuORU3jc1c/NPskD2ASinf8v3xnfXeukU0sJ5N6m5E8VLjObPEO+mN2t/FZTMZLiFqPWc/ALSqnMnnhwrNi2rbfg/rd/IpL8Le3pSBne8+seeFVBoGqzHM9yXw==)
changed: [default] => (item=gitlab.com ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIAfuCHKVTjquxvt6CM6tdG4SLp1Btn/nOeHHE5UOzRdf)
changed: [default] => (item=gitlab.com ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQCsj2bNKTBSpIYDEGk9KxsGh3mySTRgMtXL583qmBpzeQ+jqCMRgBqB98u3z++J1sKlXHWfM9dyhSevkMwSbhoR8XIq/U0tCNyokEi/ueaBMCvbcTHhO7FcwzY92WK4Yt0aGROY5qX2UKSeOvuP4D6TPqKF1onrSzH9bx9XUf2lEdWT/ia1NEKjunUqu1xOB/StKDHMoX4/OKyIzuS0q/T1zOATthvasJFoPrAjkohTyaDUz2LN5JoH839hViyEG82yB+MjcFV5MU3N1l1QL3cVUCh93xSaua1N85qivl+siMkPGbO5xR/En4iEY6K2XPASUEMaieWVNTRCtJ4S8H+9)

TASK [wordpress-install : Setup packagist.com authentication] ******************
skipping: [default] => (item=None)

TASK [wordpress-install : Install Dependencies with Composer] ******************

Has anyone found a solution to this? It’s so odd.

I bought a new Macbook Pro this weekend after developing on both linux and macos machines (ubuntu 16.04 / up to high sierra). I went about my normal work flow of cloning a site I’m currently working on and it hangs at this exact moment with very little in the way of debug information. This is on a fresh mojave 2018 MBP.

The only differences (haven’t been to the office to check virtualbox/vagrant versions) being potentially the software versions and the fact that this is running Mojave instead of High Sierra.

A little at wits end with this. Has anyone found any concrete information or debugged this successfully?


I fixed this on OSX by downgrading Vagrant to 2.1.1. There must be a compatibility issue with Vagrant 2.2.1.

Use your respective package manager/install system to downgrade to a previous release.

This topic was automatically closed after 42 days. New replies are no longer allowed.