Windows 10 Pro - Virtualbox - ‘Vagrant up’ hangs at “Mounting NFS shared folders…”

Hi there, I’m having problems with sharing folders on Windows 10 Pro.
If I install vagrant-winnfsd then Vagrant hangs at mounting nfs shared folders . . .
If I uninstall this plugin everything seams to be ok.
Then if I try to change the type from ‘nfs’ to “smb” in vagrant.default.yml it crashes too.

I don’t know if there is a way to make it work or if I’ll have a performance problem working with this configuration.

Virtual Box - 5.2.22
vagrant - 2.2.2

Than you very much in advance.

Vagrant 2.2.2 has some known issues (w/ Windows). Downgrading Vagrant to 2.1.1 should do the trick

1 Like

Hi @Henk, thanks for your answer.

As I registered these versions in this post and it worked perfectly, I had already tested it unsuccessfully with Vagrant 2.1.5.
I’ve just tested it again with Vagrant 2.1.1 and it fails at the same point.
The strange thing is that it indicates IP - and I don’t know why.

Stderr from the command:

mount.nfs: requested NFS version or transport protocol is not supported
ERROR vagrant: The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!

mount -o vers=3,udp,vers=3,udp,nolock 


I stumbled upon this (and it surprised me):

Windows users: NFS folders do not work on Windows hosts. Vagrant will ignore your request for NFS synced folders on Windows.

P.S. I’m succesfully running Vagrant 2.1.1 on a Windows 10 Pro host w/ VMware Workstation Pro 14 and the following Vagrant plugins:

vagrant-bindfs (1.1.0)
vagrant-hostmanager (1.8.7)
vagrant-share (1.1.9)
vagrant-vmware-desktop (1.0.3)
vagrant-winnfsd (1.4.0)

What versions of vagrant plugins are you running?

1 Like

Hi @Henk and thank you for your help.

ok, you’re using VMware.
As I said above, the last time I tried to launch a Trellis project I used Virtualbox and It worked - post, but it was on Windows 10 Home not Windows 10 Pro.

These are the plugins versions I’m using now:

vagrant-bindfs (1.1.0)
vagrant-hostmanager (1.8.9)
vagrant-vbguest (0.17.0)
vagrant-winnfsd (1.4.0)

I didn’t know vagrant-share, I’m testing with it installed.

If the vagrant_ip in vagrant.default.yml is not, try updating your Windows known_hosts file for the IP address in vagrant.default.yml.

1 Like

I’ve just checked it and there is no entry for a vagrant VM, neither nor

This topic was automatically closed after 42 days. New replies are no longer allowed.