Roots Discourse

Windows (WSL) setup can't provision after following documentation steps

Good day everyone,

I’m excited to migrate several VVV setups to bedrock/trellis!
Unfortunalely I run into early stage (windows) setup issues atm.
I hope there is someone who can help me out :slight_smile:

I created a local setup by following all steps documented at https://roots.io/docs/getting-started/windows/
During the initial vagrant up, I get an error at the task wordpress-install : Install Dependencies with Composer:

dependencies (including require-dev) from lock file Package operations: 11
installs, 0 updates, 0 removals - Installing roots/wordpress-core-installer
(1.1.0): Downloading (100%) Plugin installation failed, rolling back -
Removing roots/wordpress-core-installer (1.1.0) [ErrorException]
include(/srv/www/homedeal/current/vendor/roots/wordpress-core-
installer/src/WordPressCorePlugin.php): failed to open stream: No such file

After an extensive search I found a possible cause for this:

So apparently the mix of composer and using virtualbox shared folders isn’t a good combination.
I confirmed this by adding prefer_source: true to the composer role. After that it worked fine. That’s a (non ideal) workaround, not a solution.

Using NFS instead of virtualbox shared folders would be my preferred solution.
The doc states that it can be set up inside WSL.
This doesn’t work for me. I get the same errors as mentioned in Vagrant-winnfsd not working in WSL.
There is also an open ticket for this:https://github.com/winnfsd/vagrant-winnfsd/issues/111

Is there someone with a mounted volume on a windows host that works sucessfully?
I think that the docs might need an update. If we can collect some experiences here I’m willing to contribute to that as well.

Thanks in advance!

I had a similar error too on my WSL.

A solution from this thread helped in my case:

Thanks for sharing your solution!

It does not solve the issue for me unfortunately.

Which version of composer are you using?

Using composer 1.10.1 with installers 1.7.0 still results in failed installs on my setup

oh no, this is annoying.
I had updated ^1.4 to dev-master#v1.7.0 back in 2019.