Yarn build:production fails because of Error: No configuration provided for main.scss

I have seen a previous post about this error in this post.

I get an error on a Sage project w/ TailwindCSS that I am trying to build on DeployHQ for deployment on WP Engine but not on my local instance.

Error: No configuration provided for /data/wp-content/themes/my-theme/resources/assets/styles/main.scss
at module.exports (/data/wp-content/themes/my-theme/node_modules/stylelint/lib/utils/configurationError.js:8:28)
at stylelint._fullExplorer.load.then.then.config (/data/wp-content/themes/my-theme/node_modules/stylelint/lib/getConfigForFile.js:46:15)
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

I ran the yarn build:production command on my local by Flywheel instance with no problems but when I tried to deploy on DeployHQ it generated the error.

In the previous post, someone asked for the contents of conifg.json, and here’s mine. The client’s name has been replaced with “my-theme” for privacy.
“entry”: {
“main”: [
“customizer”: [
“publicPath”: “/wp-content/themes/my-theme”,
“devUrl”: “http://my-theme.local”,
“proxyUrl”: “http://localhost:3000”,
“cacheBusting”: “[name]_[hash:8]”,
“watch”: [

Am I just missing something really obvious?

An update here. I ended up screwing up my .gitignore file in the project which caused me to accidentally delete a few files. I had to start the Sage install over in a new directory and reinstall everything. The deployment built without problems after this

This topic was automatically closed after 42 days. New replies are no longer allowed.