Roots Discourse

404 error with no indication as to why

I have a an issue that I’m not sure how to go about fixing. I am getting 404 on my local dev not white screen but a simple 404 page not found. But I can’t find where the issue is. Full disclosure server admin is not my strong area.
I think I set up debug logging correctly for nginx:
in group_vars/development/main.yml I added nginx_conf: nginx-includes/nginx.conf.child
in trellis/niginx-includes/nginx/conf.child I have

{% extends 'roles/nginx/templates/nginx.conf.j2' %}
{% block error_log %}
error_log  {{ nginx_logs_root }}/error.log debug;
{% endblock %}

If I go to my main url http://cms.pleinairarchive.test/ I get the aforementioned 404 page not found.
Nothing in the logs at /srv/www/cms.pleainairarchive.com/logs/error.log or at /var/log/nginx/error.log

The thing that seemed to start this was I imported the db down from production. I’ve checked wp-options table and the siteurl and home are pointed at http://cms.pleinairarchive.test/wp. I did a search and replace before I imported. If this sounds familiar some guidance would be great or better strategies at trying to debug this.

siteurl and home should not both point to /wp iirc. Only siteurl should include that.

updated the site url still no change. The weird thing is I only get the 404 in Safari and Firefox, cleared cache and still get 404. Chrome works however? Maybe this is vagrant? Some new weirdness with Big Sur?

I lied, this happens in all browsers. Also, it seems to be just Trellis or Vagrant under Trellis? This is happening with a clean install. VVV works fine. My lando instance (which is not vagrant) also, fine. Any clues?

This topic was automatically closed after 42 days. New replies are no longer allowed.