Activating Permalinks gives 403 Access Forbidden

I’m new to Roots but not to Wordpress and I’m having problems when activating permalinks. I can use my Roots installation fine but when I activate Permalinks it gives me a 403 Access Forbidden error.

I’m running XAMPP v3.2.2 on Windows and my http-vhost.conf contains

<VirtualHost *:80>
    DocumentRoot "C:\Users\currentuser\git\roots-test\web"
    <Directory "C:\Users\currentuser\git\roots-test\web">
        Allow from all
        AllowOverride All
        Require all granted
        Options Indexes

My htaccess is

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

By directory structure is

File permissions all see fine and I have regular WP installations with permalinks running in my local XAMPP environment.

Does any know what I could try?


It turned out my local XAMPP was not configured correctly for htaccess.

Adding the following to my http-vhost.conf entry sorted the issue.

Options +FollowSymLinks
Options +Indexes
1 Like