Add_editor_style not working on staging site

For whatever reason my editor style sheet isn’t being loaded in the editor on my staging sites on cloudways. It works on my live sites (which are also on cloudways) and in my local environments. So I don’t get why they won’t load on the staging site. I’ve tried adding the style using asset_path and also a relative url where again they work on local and on the actual live versions, but not on the staging.

I should note that I tested add_editor_style using the twentynineteen theme and it worked on the staging site. So there’s something about the staging site and sage that don’t get along when it comes to the editor style for some reason.

I was wondering if anyone might have any idea.

I noticed in another topic another user made it sound like add_editor_style wasn’t working for him and he enqueued the admin style. So it sounds like he was having a similar issue with whatever server setup he was using.

Any chance you’re inculdig some inline svgs or library? I was recently hit by when I included Swiper. (PR with patch

It doesnt not fail as obviously if the css in unminified (dev for sure but in case your production happens to run unminified too)

1 Like

This topic was automatically closed after 42 days. New replies are no longer allowed.