Roots Discourse

Add MariaDB APT Key error

Hi,

I’m on mac OSX 10.13.6 and experiencing some troubles on vagrant up on TASK “Add MariaDB APT key”
This gave me an errors :
Error fetching key F1656F24C74CD1D8 from keyserver:

gpg: requesting key C74CD1D8 from hkp server

gpg: keyserver timed out

gpg: keyserver receive failed: keyserver error

fatal: [default]: FAILED! => {“changed”: false, “cmd”: “/usr/bin/apt-key adv --keyserver keyserver.ubuntu.com --recv F1656F24C74CD1D8”, “rc”: 2, “stderr_lines”: [“gpg: requesting key C74CD1D8 from hkp server keyserver.ubuntu.com”, “gpg: keyserver timed out”, “gpg: keyserver receive failed: keyserver error”], “stdout”: “Executing: /tmp/tmp.bxoUFvIuUa/gpg.1.sh --keyserver\nkeyserver.ubuntu.com\n–recv\nF1656F24C74CD1D8\n”, “stdout_lines”: [“Executing: /tmp/tmp.bxoUFvIuUa/gpg.1.sh --keyserver”, “keyserver.ubuntu.com”, “–recv”, “F1656F24C74CD1D8”]}

And ansible failed to complete successfully,

Can you please help me on this,

Many many thanks

Mathieu.

Sounds like the request to the key server timed out. Maybe you were just unlucky and tried when the server went down. Have you tried again since?

I encountered this same issue. I was running Avast Antivirus for Mac, and found that when I disabled it, the requests to keyserver.ubuntu.com worked fine and I was able to provision.