Roots Discourse

Ansible error

I did a couple of websites with trellis/bedrock and sage, it was all ok, no problem at all.

recently i updated my macOS to Mojave 10.14.6, i started a new project, I did all the setup and I arrived at the point to use ansible-vault to encrypt the files.
but when i run ansible-vault encrypt group_vars/production/vault.yml i received the error ansible-vault: command not found

so i run ansible --version and i get ansible: command not found

so i tried to re-install again ansible with pip install ansible but i get these output (that seems that it is already installed)

Requirement already satisfied: ansible in /usr/local/lib/python2.7/site-packages (2.8.4)
Requirement already satisfied: jinja2 in /usr/local/lib/python2.7/site-packages (from ansible) (2.10)
Requirement already satisfied: PyYAML in /usr/local/lib/python2.7/site-packages (from ansible) (3.13)
Requirement already satisfied: cryptography in /usr/local/lib/python2.7/site-packages (from ansible) (2.3.1)
Requirement already satisfied: MarkupSafe>=0.23 in /usr/local/lib/python2.7/site-packages (from jinja2->ansible) (1.0)
Requirement already satisfied: asn1crypto>=0.21.0 in /usr/local/lib/python2.7/site-packages (from cryptography->ansible) (0.24.0)
Requirement already satisfied: cffi!=1.11.3,>=1.7 in /usr/local/lib/python2.7/site-packages (from cryptography->ansible) (1.11.5)
Requirement already satisfied: enum34; python_version < "3" in /usr/local/lib/python2.7/site-packages (from cryptography->ansible) (1.1.6)
Requirement already satisfied: six>=1.4.1 in /usr/local/lib/python2.7/site-packages (from cryptography->ansible) (1.11.0)
Requirement already satisfied: ipaddress; python_version < "3" in /usr/local/lib/python2.7/site-packages (from cryptography->ansible) (1.0.22)
Requirement already satisfied: idna>=2.1 in /usr/local/lib/python2.7/site-packages (from cryptography->ansible) (2.7)
Requirement already satisfied: pycparser in /usr/local/lib/python2.7/site-packages (from cffi!=1.11.3,>=1.7->cryptography->ansible) (2.18)

i tried also to uninstall and then install again with pip uninstall ansible and then again pip install ansible but with no luck.

i tried also with sudo pip install ansible but i get the same output “Requirement already satisfied…”

do you have any idea what else I can try to do?
any suggestions are welcome because i am stuck with this :frowning:

The issue is with your $PATH environment variable. Right now it doesn’t seem to contain the necessary path to your Python binaries.

This has more details: https://stackoverflow.com/questions/35898734/pip-installs-packages-successfully-but-executables-not-found-from-command-line/35899029

thanks @swalkinshaw, i think that i found a solution with this > Bash: line 5: pip: command not found

it seems ok now, i uninstalled ansible-2.8.4 and installed installed ansible-2.7.5.

now i can encrypt the vault files.

thanks :wink: