Roots Discourse

Ansible Playbook-CLI AttributeError since updating to Catalina

Hey guys,

I recently updated to macOS Catalina, and everything has been running fine since. But when I go to deploy or provision a site (on Trellis/Bedrock/Sage), I get the following error:

Traceback (most recent call last): File "/usr/local/bin/ansible-playbook", line 129, in <module> have_cli_options = cli is not None and cli.options is not None AttributeError: 'PlaybookCLI' object has no attribute 'options'

Here it is in verbose mode.

I’m pretty sure I’ve tried solutions from all related threads. I’m on Ansible version 2.8 and Python version 2.7.16.

I’m assuming this is a new bug caused by updating to Catalina, since this is the first time I’ve tried to deploy since updating my OS. I’m going to test out some deploys with other sites to troubleshoot meanwhile, but any tips or help would be appreciated. Thanks!

:thinking: I know some people ran into this on < 2.8 before but that was a while ago before we had proper 2.8 and now 2.9 support. Maybe just try a newer Ansible version?

1 Like

Thanks Scott!

I had been on 2.8 for a long time, at least 6-12 months. All my sites were being maintained just fine. I updated to Catalina last week, vagrant up’d all my machines, and they all worked fine. It wasn’t until I went to go deploy one (created back in 2018), and it hit this error.

I updated to 2.9-2.9.7 and I got: ERROR! Unexpected Exception, this is probably a bug: 'PlaybookCLI' object has no attribute 'options'

I then downgraded to Ansible 2.7.17 and everything started working again.

I upgraded back to 2.9 and tested my most recent site (created a couple weeks ago), the deployment worked fine.

Switching versions is a good quick fix for now. If I want to fix it for good, I’ll probably have to update Trellis on my older projects.

Yep that makes sense :+1: It was a mismatch between Trellis code and Ansible version

1 Like

This topic was automatically closed after 42 days. New replies are no longer allowed.