-bash: ansible-galaxy: command not found

I’m stuck and hoping for a little direction from you lovely people :smile:

I’ll try to be concise with a few questions:

I’ve got a Digital Ocean droplet setup and working, but rather than setting up the server using Trellis I’ve setup via serverpilot.io - I’m not a sysadmin and using this will apparently help!

  1. Can I still setup Vagrant on my local machine by using Trellis, and then deploy via the Bedrock-Capistrano method? (Not touched B-C yet, just want to check this is possible first)

Assuming (1) is possible…

  1. I’ve installed vagrant, virtualbox and ansible as per the Trellis docs - when I run “ansible-galaxy install -r requirements.yml” I am getting the error “-bash: ansible-galaxy: command not found”.

I’ve tried installing ansible at my user root, my project root and inside the trellis folder. What am I missing? Why the error?

If (1) is not possible and I should not be using Trellis anyway…

  1. can anyone point me in the direction of a vagrantfile or tutorial that will help me install nginx, php5.6 and mysql on ubuntu 14.04? (this is the basic setup that serverpilot.io installs on my DO droplet)

Thanks as always!

  1. Yes that’s possible.

  2. How did you install Ansible?

1 Like

Hey Scott,

I just ran git clone git://github.com/ansible/ansible.git --recursive

Looks like you tried the Running From Source approach. You might try an alternative such as Latest Releases Via Pip.

1 Like

Thanks Phil, thats worked!

So had some trouble with this today…first time setting up trellis. Installed via pip at first but ansible-galaxy worked after installed via brew.

1 Like